0

I am using Sitecore 8.2 Update 5. I created one folder item "Days in Year List" under which I created 365 items which represent 365 days of a year. I set this year folder path to "Source" in template field of type droplist.

When I am chekcing values under this droplist in content tree item, I am getting list upto 260 items only. All items after 260-365 are missing.

Do anybody know how to show all items in droplist or droplink?

enter image description here

2
  • 1
    Why not use an integer field and a field validation to restrict the range. A dropdown with more than 25 options could mean a poor user experience. Jan 3 '18 at 14:16
  • This question made me die a little inside ;)
    – Abhay Dhar
    Dec 3 '19 at 7:26
5

https://ggullentops.blogspot.be/2016/03/querymaxitems-in-sitecore-81.html

As from Sitecore 8.1 the Query.MaxItems value is patched in Sitecore.ExperienceExplorer.config and set to 260. This means that Sitecore queries will fetch only the first 260 items.

You can adjust this setting if needed or make sure that you don't have that many items in the droplist. As Michael mentioned, it will be a bad UX if you have that many items in the droplist... also consider performance - Sitecore did put a max on the result set for a reason ;)

As mentioned in the comments - don't use a droplist/droplink for your solution. Integer will work better for you (with validator if needed).

2
  • 1
    @SurendrA will be better if you will use Integer field type. For control correct day number you can implement custom validator and also control max day number for leap year Jan 3 '18 at 14:29
  • @gatogordo Thanks for quick response. I thought about integer value, but in that case user have to enter its value which I am trying to avoid. So thats why I picked droplist. I was aware of "Query.MaxItems" with 100 and checked its value in Sitecore.config. But I was not aware about new patch setting in "Sitecore.ExperienceExplorer.config". Thanks to update me. Jan 3 '18 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.