0

I have issue in Multi list with Search in Sitecore. I'm using Sitecore 8.1 along with Solr 6.5. I'm using the below query to load the items in the multi list. Items are loading perfectly on English version. But when I switched to Italian version for same item, no items are loading.

Query:

StartSearchLocation=query:./ancestor::*[@@templatename->'Site Folder']//*[@@templatename->'Products Folder']

When I googled for this issue many recommend that to use the latest version filter in the query. So I did like this.

StartSearchLocation=query:./ancestor::*[@@templatename->'Site Folder']//*[@@templatename->'Products Folder']&Filter=+_latestversion:true

But this also doesn't help me. When further digging on this issue I got some hint which says,

This will happen when an item has more than one version. Not in the means of language but multiple versions in same language.

So I tried removing multiple versions in same language. Also no luck. Same query working for other languages. But issue is in Italian language only.

Can someone please help on this issue to get solved? Yes I know Multi list with search has bugs, but more than that my requirement was to use multi list with search. Please do let me know if I missed anything.

1

Issue solved by updating to latest patch file Sitecore.Support.406408. Thanks.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.