I'm using Sitecore 9, and SXA 1.7

I have a search scope that searches for certain items whose template is "blog page", in the scope query, I'm searching using the template and location, and I do get the items requires as results.

However, when I use the Search result component in a page and give it the previously mentioned scope, it does not show me any results.

I do not know the reason for this, if anyone ran into anything similar I would appreciate some guidance.

  • What is the location of those items? Jun 12, 2018 at 18:13
  • in the SXA tree under Home/Media/Posts, The scope query search shows the items i'm looking for (when i'm writing the query), but for some reason it stopped working when i use it inside the "search result" component on a page. I think it's an issue with solr. I tried rebuilding the indexes but that didn't help Jun 14, 2018 at 12:30
  • 1
    Be sure that your template inherits from _Searchable template (/sitecore/templates/Foundation/Experience Accelerator/Search/Computed Fields/_Searchable).
    – Norbert
    Jun 15, 2018 at 11:51
  • I checked and made it inherit from _Searchable, but it didn't work. I tried restarting solr service, Rebuilding the indexes multiple times, and it still does not work. The query inside the scope shows the results, but using it in the search result component on a page doesn't show a thing. it's driving me crazy. Jun 24, 2018 at 11:17
  • You need delete items and recreate again after assigning _searchable base template
    – user16181
    Aug 27, 2018 at 19:28

2 Answers 2


I have tried many of the suggested solutions in the comments, but at the end what fixed it for me was rebuilding the index, i'll list the things I needed to check first below:

  • Make sure that your template inherits from _Searchable template (/sitecore/templates/Foundation/Experience Accelerator/Search/Computed Fields/_Searchable).
  • Make sure that you set that inheritance in the template first, then create the items you need, and check the search result for the new items.
  • Try rebuilding your indexes, from the Sitecore launchpad, in configurations, indexing. (this is what worked for me)
  • Make sure that your search result component has a rendering variant set to it, and that the rendering variant is reading the correct fields from your items.

It is possible to build the query for search scope without sitecore_sxa_master_index core (website_master_index will be used instead).

If none of the solutions above solve your issues, probably you missed the "Create SOLR SXA cores" part during your SXA installation process:

  1. Duplicate the core directory created for sitecore_master_index (or company_name_master_index) twice and rename it to:

     • sitecore_sxa_master_index
     • sitecore_sxa_web_index
  2. In those two folders, remove everything besides the "conf" directory.

  3. On the Solr web interface, click Core Admin, and click Add Core to add sitecore_sxa_master_index. Do the same for sitecore_sxa_web_index

  4. Populate schema and rebuild indexes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.