1

I am getting error as Connection refused to remote server while accessing message in Email Campaign Manager.

I was trying to test by sitecore/admin/ECM.requestbody.aspx where it's connecting to wrong rendering URL which got modified when we moved our server to https.

I modified the Rendering URL field manually and clicked on 'Check'. Now I get Could not create SSL/TLS secure channel.

So, I navigated to System/Email Campaign Manager/GlobalSettings to configure Rendering URL field. But I don't see that field there. Do I have to upgrade ECM version to configure Rendering URL field.

Am I going in right direction? Please give me some input in resolving this.

2

The answer by @bartłomiej-mucha is true for version 3.5 and above. In older versions of EXM (and ECM) you have to resort to implementing an extension as explained in Customize the Renderer URL setting in ECM:

To be able to specify the Renderer URL manually, you can implement a small extension.

Check the following example:

Create a custom processor to update the Renderer URL with the value from a configuration file. For example:

public void Process(PipelineArgs args)
{
  Sitecore.Modules.EmailCampaign.GlobalSettings.RendererUrl = Settings.GetSetting("ECM.RendererUrl");
}

Add this processor to the pipeline of the web.config:

<pipelines>
  <initialize>
    ...
    <processor type="<your-processor-class-name, your-assembly" />
  </initialize>

Specify the required value of the ECM.RendererUrl setting in the web.config. This address should be accessible from the ECM server (where the message is being created and dispatched) of your Sitecore environment:

<settings>
  ...
  <setting name="ECM.RendererUrl" value="http://yourhost" />
3
  • Thank you. I am trying this. Any idea under which namespace GlobalSettings come under? or I have to fetch 'System/Email Campaign Manager/GlobalSettings ' and update? – user8927358 Dec 3 '18 at 9:29
  • @user8927358 Sitecore.Modules.EmailCampaign – Jacob Nielsen Dec 3 '18 at 10:37
  • Able to set the rendering Url with above steps. Thank you for the help :) – user8927358 Dec 4 '18 at 6:46
2

Version Note: This answer applies to EXM 3.5 or Sitecore 9.X only.

You can configure EXM.RendererUrl in the Sitecore.EmailExperience.Core.config config file.

In case the setting is empty, the RendererUrl is resolved on the first request to the application. In the <httpRequestBegin> pipeline, there is a Sitecore.Modules.EmailCampaign.Core.Pipelines.HttpRequestBegin.OnHttpRequestBegin processor that that does that:

GlobalSettings.RendererUrl = WebUtil.GetServerUrl(args.HttpContext.Request.Url, false);

You said that it worked ok previously on HTTP, but after you switched to HTTPS, it does not work. First I would focus on fixing the SSL/TLS issue. I bet that there is some problem with the certificate.

1
  • After moving to https hostname has been changed and we are using old ECM version only still. So, I assuming some settings issue only. Because after moving to https all other things are working fine except ECM. Any idea why Rendering URL field is not shown in Email Campaign Manager -> Settings -> Global Settings item? – user8927358 Dec 3 '18 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.