0

I have a problem with EXM on a multisite environment. The application has two sites on the CD, e.g. test.com and test-test2.com. For each of them is configured ManagerRoot with the corresponding values in the base url.

A subscription mail has a valid start, e.g. test-test.com/sitecore modules / web / exm / redirecturlpage.aspx ... But after clicking on it, we are redirected to the CM server, e.g. test.cm/sitecore modules / web / exm / configsubscription.

Has anyone an idea what this may be due to?

2

If you have multiple sites then it is a better solution to create custom hostname mapping. To create a custom hostname mapping, please follow below steps:

  1. Go to this location /sitecore/system/Settings/Email/System/Hostname Mappings
  2. Create new Hostname Mappings
  3. Insert Original and Public URL.

For more information, you can follow this link https://doc.sitecore.com/developers/exm/90/email-experience-manager/en/link-generation-and-hostname-mapping-in-exm.html

1
  • Hi, I have a follow up question for this one: We have multiple frontends (site1, site2, site3), each of them have their own manager root. They all share the same CM url (cm.site). How am I supposed to map this via hostname mapping? They way I see it works, each cm url only corresponds to a single frontend url (1:1, instead of 1:m) – Christopher Huemmer Mar 17 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.