2

I want to set the language in the dropdown -as shown in the image below- to another language on a per user basis.

Our website is only in Japanese. Every time a new item is created or the page loads, the author needs to change the language to Japanese from English and then start editing.

There are language settings for each user in the User Manager > Edit User screen. But when I set the Default Content Language to Japanese, the names of the nodes in the content tree like "content" or "media library" change. I just want to set the language in the dropdown.

Is this possible?

enter image description here

UPDATE
I have followed @Gatogordo's solution. The default language in the dropdown has changed but the default sitecore nodes show in japanese.

enter image description here

3

You can -as you already noticed- use the language settings for the user to switch his default content language to Japanese.

By default Sitecore will display the Display Name of the item in the content tree though. As you see the names changing there, I assume you are using display names in Japanese. If you don't want the content editor to behave this way you can turn this off to make it use the actual name (instead of the display name).

In the content editor, go to the red hamburger menu (top left) to find the Application options. In the View tab you will find the Content Tree - Item names setting. Set this to Item key instead of Display name. That should turn it off.

enter image description here

  • I selected Item key. It still shows japanese even after a logout & login – Qwerty Sep 19 at 9:17
  • Are the item names in Japanese? What happens when you switch the item to English? – Gatogordo Sep 19 at 9:39
  • The names as you can see are default sitecore nodes & now display in Japanese, even when I change the dropdown to english. The custom items created are however in the original name - english – Qwerty Sep 19 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.