3

I'm trying to set up Commerce Engine v9.2 Visual Studio Development Environment. Previously, I did install and configure the Sitecore Experience Commerce v9.2 locally and I did get the issue. I did reinstall it and I'm getting the same issue.

Below are the steps that I followed and the issue.

My Steps:

1. I cleaned up (manually deleted) everything related to the previous installation. Including database, windows services, websites, website folders, Solr,... (even windows/temp folders)

2. I did reinstall Solr/Sitecore XP 9.2 and Sitecore Experience Commerce v9.2 without any issues using SIF.

3. I did clean up the databases, rebuild link indexes, rebuild the indexes and republished the site.

4. I can access Sitecore Launchpad, SXA storefront and Business Tools (https://bizfx.ecms.com).

5. I followed this instruction to setup Visual Studio Commerce Engine Development enviorment enter link description here

6. I stopped "CommerceAuthoring_ecms" AppPool and Site

7. When I run the Sitecore.Commerce.Enginee "Engine" it looks like it is running correctly.

enter image description here

8. However, when I try to navigate to business tools I'm getting an issue.

9. This is the same issue that I was getting in the previous installation.

10. This issue is that I can't access the business tools.

enter image description here

11. When I run the Sitecore.Commerce.Engine in "IIS Express" I'm getting the https://localhost:5000/api/$metadata page. Which looks ok. However, I can still not access business tools.

12. I did check and updated the Global.json and Config.json files. I also updated logs from Warning to debug.

13. I don't see any error in Sitecore logs as well as Sitecore.Commerce.Engine logs.

14. I did google and find similar issue but there was not a solution.

15. Can somebody give me an idea of how should I debug to find this issue?

16. After @VipinBanka suggestion I checked the developer tools network calls. It looks like the request is still going to authoring website.

enter image description here

  • Note: In debug mode, I can still access the sxa.storefront.com. – Ercan Polat Sep 22 '19 at 4:10
  • can you check network calls in your browser developer tools and see if there is any error? – Vipin Banka Sep 22 '19 at 4:18
  • @VipinBanka Yes, there are several errors and it looks like the request is going still to the authoring website. I'm not sure where can I configure this. – Ercan Polat Sep 22 '19 at 4:37
  • you can configure the url in SitecoreBizFx\assets\config.json file, there is EngineUri property for that, BizFx should connect to your authoring environment though, why you want to change it? – Vipin Banka Sep 22 '19 at 4:44
  • @VipinBanka please check my answer below. I did change it in order to set up the Visual Studio Sitecore.Commerce.Engine project to debug locally. Thank you very much for your help. Please, let me know if this answer makes sense. – Ercan Polat Sep 22 '19 at 4:59
2

After @VipinBankas suggestion, I did find out that the request was still going to Authoring website. Since we did turn off Authoring AppPool and Website which were using port 5000, the request was failing. In order to use Sitecore.Commerce.Engine the request should go to "https://localhost:5000".

Basically, after I updated SitecoreBizFx\assets\config.json file EngineUri to "https://localhost:5000". The issue was solved.

Note: That "https://localhost:5000" is redirected by Kerstel server to "https://localhost:4200/"

enter image description here

Result:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.