2

I have installed Sitecore XC 9.2.0 using the ARM template. When I am trying to access the "BizFX" site, I am getting couple of 400 bad request errors in api/GetNavigationView() & api/GetLanguagesView()

When I have opened the network tab, I found the actual error saying,

"Text": "Entity 'HabitatAuthoring' was not found.", "CommerceTermKey":"EntityNotFound"

I have also changed the default environment name in the BizFX config file as I was providing a different "environmentName" in ARM template. But that didn't resolve the issue.

After putting the new environmentName same error is showing with the new environmentName.

The actual error I am getting:

{ "@odata.context":"https://sitecorexc920-authoring.azurewebsites.net/Api/$metadata#Sitecore.Commerce.Core.CommandMessage", "MessageDate":"2019-10-12T07:14:07.4268526Z","Code":"Error","Text":"Entity 'HabitatShops' was not found.","CommerceTermKey":"EntityNotFound" }

enter image description here

Can anyone pls help to get out of this?

  • Did you solve this issue? If not can you provide the "Deploy-Sitecore-Commerce.ps1" file and SitecoreBizFx/assets/config.json. It might be some configuration mismatch. – Ercan Polat Oct 15 at 20:19
  • Yes. I was putting "INR" in the currency field in the ARM template. Putting "USD" was resolved the issue. But try once to bootstrap the sitecore application. This should also work. – Arkadeep Oct 15 at 20:23
1

The problem was due to the currency field in the ARM template. Changing "INR" to "USD" solved the issue.

  1. In BizFX config.json file change the currency to "USD"
  2. Bootstrap the Sitecore.

Or

  1. Install the ARM template using "USD" would not require the above post-installation steps.

After all these add your own currency.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.