0

while installing Sitecore 91 (solr 7.2.1 running as windows service), SIF is throwing below exception.

[ XConnectXP0_CreateShardApplicationDatabaseServerLoginS... : Command
-------------------------------------------------]
Install-SitecoreConfiguration : Cannot validate argument on parameter 'Path'. The running command stopped because the
preference variable "ErrorActionPreference" or common parameter is set to Stop: The term 'sqlcmd' is not recognized as
the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was
included, verify that the path is correct and try again.
At D:\Sitecore91\XP0-SingleDeveloper.ps1:74 char:1
+ Install-SitecoreConfiguration @singleDeveloperParams *>&1 | Tee-Objec ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:04:18
Invoke-CommandTask : Cannot validate argument on parameter 'Path'. The running command stopped because the preference
variable "ErrorActionPreference" or common parameter is set to Stop: The term 'sqlcmd' is not recognized as the name
of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included,
verify that the path is correct and try again.
At C:\Program
Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.1.0\Public\Install-SitecoreConfiguration.ps1:641 char:47
+                         & $entry.Task.Command @paramSet | Out-Default
+                                               ~~~~~~~~~
    + CategoryInfo          : InvalidData: (:) [Invoke-CommandTask], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : ParameterArgumentValidationError,Invoke-CommandTask

I've tried verifying environment variables for sql server as exception includes

"The term 'sqlcmd' is not recognized as the name of a cmdlet,""

below is my environment variables setup for sql server

enter image description here

Please could you help me understand what could be causing this?

0

sqlcmd.exe is part of the Microsoft Command Line Utilities 13 for SQL Server

Did you executed Prerequesities script? In Powershell: Install-SitecoreConfiguration -Path .\Prerequisites.json

(Prerequisities.json is part of the scripts provided by Sitecore)

It will install everything required for the Sitecore installation (not only SQL related things, but also checks for proper version of .NET framework and other tasks.).

The second option is to install following tools:

https://www.microsoft.com/en-us/download/details.aspx?id=50420

https://www.microsoft.com/en-us/download/details.aspx?id=52680

But preffered way is (at least for me) to install it via prereq script.

Tomas

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.