0

This is a fresh 9.3 instance. I'm unable to preview any page. On clicking preview, it opens a page which has this error:

enter image description here

I'm logged in as Admin. It did not happen with other instances like 8.2. Are there any settings to be made.

Here is my MySiteDefinition.config:

<site name="MySite" virtualFolder="/" physicalFolder="/" rootPath="/sitecore/content/MySite" 
startItem="/home" language="ja-JP" database="web" domain="mysite" allowDebug="true" 
cacheHtml="true" htmlCacheSize="50MB" enablePreview="true" enableWebEdit="true" 
enableDebugger="true" disableClientData="false" 
dictionaryPath="/sitecore/content/MySite/Global/Dictionary" dictionaryAutoCreate="false" />
  • Can you check in your siteSettings if you have requireLogin="true"? – Ghanendra Singh Feb 27 at 9:20
  • @GhanendraSingh In my SiteDefinition.config, there is no requireLogin property at all. – Qwerty Feb 27 at 9:57
  • @Qwerty did you check the permissions assigned? Make sure that the Anonymous user has read rights to the item. – PSS Feb 27 at 15:39
1

Check the below setting in Sitecore.config

<!-- PREVIEW AS ANONYMOUS
       This setting specifies whether Sitecore will use the Anonymous user account when you preview an item.
       If true, Sitecore uses the Anonymous user account when you preview an item.
       If false, Sitecore uses the current user account when you preview an item.
       Default value: true
  -->
    <setting name="Preview.AsAnonymous" value="false" />

Default is "true" so whenever you preview in Sitecore versions 9.1+, it will take "Anonymous" user context and if you have security to disable access for anonymous then the page might throw an error. Change it to false if you want to run preview in logged-in user context.

In your case the error screen shot clearly says that the preview user was "extranet\Anonymous" though you logged in as admin and previewed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.