0

Sitecore 8.2 update 3. Just installed WFFM 8.2 update 3. Local (to CM) MongoDB for analytics (if that matters?)

I created a template for an item to save the results of a form submission and made "Create Item" as the only save action for the form. Mapped the form fields to the template fields and set a destination. The template consists of fields from itself as well as fields from base templates.

When installing WFFM, I did run the WFMM_Analytics.sql file on the reporting database (not doing this seems to be a common mistake). I made sure the new tables were created.

I made sure "Client Action" is checked for the save action. (tried unchecked as well).

I added read/write/create permissions for "default/anonymous" to the folder where the items are to be created and made sure descendants was also checked.

Scroll down for update to this post with new errors
When submitting the form on CM, I get an error on the page:

We experienced a technical difficulty while processing your request. Your data may not have been correctly saved.

The message in the log is

1536 12:45:05 ERROR Exception when storing an aggregation result into reporting database. Item will be postponed and retried later.
Exception: System.Data.SqlClient.SqlException
Message: Invalid object name 'FormFieldValues'.

When submitting on CD, it gives me a success message but saves nothing. In the log I see this:

5480 15:54:12 WARN '{92F54CF7-F295-45A7-BBEC-E09F10126A19}' is not valid datasource.
5480 15:54:12 WARN '{96C90A1F-8464-4E69-850C-5515915B990A}' is not valid datasource.
5480 15:54:12 WARN '{4C9DF4E6-DD1F-4F3C-A86B-55807D6E1926}' is not valid datasource.

I have published the entire site.

Update

I learned how to change my wffm data from the analytics database (mongoDB default) to SQL using this article: https://www.linkedin.com/pulse/how-power-sitecore-wffm-through-sql-rohit-chopra/

Now when I submit the form from the CM, I get the following error in the log:

ManagedPoolThread #9 09:31:10 INFO Scheduling.DatabaseAgent started. Database: master
4344 09:31:10 WARN [WFFM] The '/sitecore/content/Home/Form Submissions/Contact Us' item has not been found.
Exception: Sitecore.Exceptions.RequiredObjectIsNullException
Message: The '/sitecore/content/Home/Form Submissions/Contact Us' item has not been found.
Source: Sitecore.Forms.Custom
at Sitecore.Form.Submit.CreateItem.CreateItemByFields(ID formid, AdaptedResultList fields)
at Sitecore.Form.Submit.CreateItem.Execute(ID formId, AdaptedResultList adaptedFields, ActionCallContext actionCallContext, Object[] data)
at Sitecore.Forms.Core.Dependencies.DefaultImplActionExecutor.ExecuteSaving(ID formID, ControlResult[] fields, IActionDefinition[] actionDefinitions, Boolean simpleAdapt, ID sessionID)

The item mentioned in lines 2 and 4 above do exist in the master and web databases. it is a folder meant to store form submission items from this form.

  • What do you your formsDataProvider set to ? are you storing into SQL or Mongo? – Ahmed Okour Apr 15 at 21:00
  • MongoDB, but I wanted it to be SQL. This is the first I read about it (wasn't in the installation guide). I searched on it and found linkedin.com/pulse/… which seems to have helped. Now I have a different error: Updating the original post. – Michael Apr 16 at 13:33
  • can you change that folder path so it does not have spaces? also make sure the folder exists in all language versions if you have any – Ahmed Okour Apr 16 at 15:00
  • No effect. It is working now that I have altered the template. What I neglected to mention is that the template I was using for the created item had two base templates. When I removed these and incorporated their fields directly into the template, it started working... I don't understand why this would correct the problem, but it worked. – Michael Apr 16 at 15:37
0

To resolve the original problem, I was able to update my installation to use SQL instead of MongoDB (default) for WFFM. After that, the second issue I ran into was resolved by removing base templates and incorporating all fields into a single template.

I don't know why this would work, so if anyone can give better details, I would mark their response as the answer.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.