0

I upgraded an instance from Sitecore 9.1.1 to 10.0 after the upgrade when I enter the experience analytics the graphs don't show and I got those errors


The TopTenCampaignsByValue graph cannot be displayed due to a server error. Contact your system administrator.

The OnlineInteractionsByVisitsAndValuePerVisit graph cannot be displayed due to a server error. Contact you system administrator.

The ChannelsByVisits graph cannot be displayed due to a server error. Contact you system administrator.

The TopTenPatternsByValuePerVisit graph cannot be displayed due to a server error. Contact you system administrator.

The OnlineInteractions graph cannot be displayed due to a server error. Contact you system administrator.

The TopTenGoalsByConversions graph cannot be displayed due to a server error. Contact you system administrator.

and the API response is (500)

Request URL: https://rjupgrade.sc/sitecore/api/ao/aggregates/all/56649EAC3CCF4EAB88B0C74862DB862B/all/%7B8085A926-81C0-4AF4-B3C8-2DE0D06438CF%7D?&dateGrouping=by-auto&&keyOrderBy=visits-Desc&dateFrom=10-12-2020&dateTo=09-03-2021&keyGrouping=by-key

the error:

{
"message":
"An error has occurred.",
"exceptionMessage":"The required anti-forgery form field \"__RequestVerificationToken\"
is not present.",
"exceptionType":"System.Web.Mvc.HttpAntiForgeryException",

"stackTrace":"  
at System.Web.Helpers.AntiXsrf.TokenValidator.ValidateTokens(HttpContextBase httpContext, IIdentity identity, AntiForgeryToken sessionToken,
AntiForgeryToken fieldToken)\r\n   
at System.Web.Helpers.AntiXsrf.AntiForgeryWorker.Validate(HttpContextBase httpContext)\r\n   
at Sitecore.Web.Http.Filters.ValidateHttpAntiForgeryTokenAttribute.OnAuthorization(HttpActionContext actionContext)"}

I checked the connection strings, the app settings for the xConnect instance and I also checked the certifications. Any idea why this is happening?

4
  • 1
    Can you try to take a look at the sitecore and xconnect log files to see what errors are logged? Mar 10 at 13:25
  • I found this yestrday 2021-03-09 17:21:54.818 +02:00 [Error] Access to the registry key 'Global' is denied. System.UnauthorizedAccessException: Access to the registry key 'Global' is denied. I added the instance to Performance Monitor Users and Performance Log Users then I didn't get the error again in the logged files the xConnect instance works fine Mar 10 at 13:37
  • seems like Certificate issue, we had similar issue when certificate expired Mar 11 at 2:02
  • I checked the certification its valid Mar 11 at 7:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.