0

I'm having an issue when I try to browse my Sitecore 10.1 CM Container in the browser. The message I get is a 404 error.

Investigating a bit more I checked traefik logs and saw lots of errors:

*Failed to retrieve information of the docker client and server host: error during connect: This error may indicate that the docker daemon is not running.: Get \"http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.24/version\": open //./pipe/docker_engine: The system cannot find the file specified." providerName=docker*

This is happening on a 10.1 OOB Sitecore image. The side effect to this is me trying to open the cm instance i.e cm.myinstance.localhost in the browser and it throws a 404 for a valid hostname running in my docker instance. If I update the compose file setting a port to the CM instance I can browse using that port only but not without the port. My understanding is that 443 should be handled automatically from traefik and redirect the request to the cm instance causing cm.myinstance.localhost to work without the need of setting a port in the cm image. is that correct? All docker containers are green, up and running. Here are a few things I already tried:

  • composed up using both the new commands docker compose up and docker-compose up and the outcome is the same
  • restart docker services
  • restarted Docker Desktop
  • restarted the laptop
  • restored default factory configurations on Docker Desktop

Any help is much appreciated here

1
5

I had this problem on my local. I had all containers green in docker desktop, but got the same error as you. Even after I restarted Docker, it still did not work for me.

I have an on-prem version of v10.1 installed as well, and whilst I had stopped IIS, I realised some services were still running which were installed. Stopping the follow services, fixed my issue

  • Sitecore Marketing Automation Engine
  • Sitecore Processing Engine
  • Sitecore XConnect Search Indexer
1
  • I had the same issue and following this recommendation fixed my problem. Thanks John!
    – Diego
    May 24 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.