0

I am running on Sitecore 10.1. I have installed the latest available DAM Connect Sitecore Connect for Sitecore DAM-2.0.0.zip and configured it as per the instruction given in the installation guide.

When I tried to add the assets from DAM by clicking on the icon from the toolbar, It shows me an empty page titled Insert from Sitecore DAM.

I checked this connector's compatibility matrix, I found that this connector has not been tested on Sitecore 10.1.

This Sitecore Connect™ for Sitecore DAM™ has been tested on Sitecore Experience Manager and Sitecore Experience Platform (versions 9.1.0, 9.1.1, 9.2.0 or 9.3.0), as well as Sitecore Experience Commerce (versions 9.1.0, 9.1.1, 9.2.0 or 9.3.0).

Now little curious, how to resolve that issue for 10.1. Any clue?

Update 1 When I looked into the browser console, I got the below exception.

Multiple types were found that match the controller named 'MContent'

enter image description here

Is this because I have installed Sitecore Connect for Sitecore DAM-2.0.0.zip along with Sitecore Connect for Content Hub XP for 10.1 v. 4.0.0 rev. 00229?

4
  • Better to check App_Config in the package and check which processor is running and then decompile the DLL to understand how it is working and where it can throw the error by what reason. Then it can give you a hint. Jul 3 at 11:37
  • hey Arvind, are there any errors in your browser console? The connector will display an iframe that renders a CH page. Might be CORS issue
    – josedbaez
    Jul 7 at 8:10
  • Hey @josedbaez. Good catch again. How could I miss checking this in the browser console. Yes I am getting 500 internal server error. Updating my question. Jul 7 at 14:01
  • Hey @josedbaez, Yes. Your clue worked again. I removed dll and config file of DAM-2.0.0 package and it started working. Please post this as an answer and I will accept that. Jul 8 at 3:20
1

The connector renders an iframe that loads up Content Hub. Open your browser console to try spot the error being thrown.

Your updated question shows the error of a missing controller. Most likely you have wrong DLL versions of the connector (maybe something else is replacing a DLL it uses), or a web.config setting is blocking the api endpoint.

Compare the versions of DLLs deployed to the web folder with the ones provided in the package.

2

For Sitecore 10.1 you need to install Sitecore Connect for Content Hub 4.0.0 - Since v3, Connect for DAM and Connect for CMP were merged into a single package.

3
  • I tried that too. Added the required connection string in the config file but still empty page. However, my Sitecore instance is not publicly accessible. This could be the cause of the issue? Jul 5 at 15:55
  • No - I can run the connector find on a local instance. Have you setup your CORS correctly for your local domain?
    – Richard Seal
    Jul 5 at 16:45
  • Yes. I did. But still the same empty page. Jul 6 at 4:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.