3

I've created a role that can only see watermarked versions of certain assets. Rather than displaying a watermarked preview, the assets are not being shown at all. The Preview rendition is configured to create a watermarked version. I'd like to know:

  1. If a security or other configuration task has been missed.
  2. How to effectively troubleshoot a rendering 404 issue.
  3. Is this behavior expected.

Asset Detail Page missing preview

How my page is displaying. Note gap on top left. Preview rendition also returns a 404. enter image description here

Security Roles

Security roles set on this role. (Update: I've also added read access to M.File, per Ronald's reply.) enter image description here

Content Hub 3.4.6, and reproduced on 4.0.0

Additional information:

  1. Per Ronald's suggestion, I have added read access to M.File. This did not resolve the issue.
  2. For the preview image (technically, the Entity Image Viewer component output), the image is rendered with a URL for a Superuser:
src="https://dan-solovay-346-empty.sitecoresandbox.cloud/api/delivery/local-15af4ed5a70b433bb6903925d8d4af24?expires=2022-05-10T17%3A09%3A06.0390071%2B00%3A00&entityid=29984&userid=29706&rendition=preview&signature=loXVaDCXgRA)"

but for the user without "ViewWithoutWatermark", the src value is replaced with a small amount of inline binary:

src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"
  1. If I create a "watermark_preview" rendition, as documented here, that rendition is visible to the user in a watermarked state: enter image description here So watermarking is working fine for this user; the issue is with the watermark behavior of the Preview rendition. However, only Preview and Thumbnail are allowed options for the Entity Image component, enter image description here so there is no way to make use of this rendition to display a watermarked preview on the Asset Detail page. The permissions on the watermarked_rendition are identical to Preview itself, so that doesn't look to be the issue. watermarked_rendition permissions Preview permissions

3 Answers 3

2

To fix this, I did the following:

  1. Go to Manage/Watermarks
  2. Open Default Watermarks. Remove the Preview rendition from Rendition Links, and save.
  3. Add Preview back to Default watermark and save. The watermark user should now see this:

Asset Detail with Watermark

At this point I was able to move the Preview rendition back to the default watermark and remove the temporary watermark, and the display remained functional.

Note that this display requires very minimal permissions: Permissions image, with just Portal Page and M.Asset enabled.

1

Even I had a similar issue and this blog didn't have the solution for my issue but yes and it pointed in the right direction. So adding my solution and help in troubleshooting. Under the Watermarking Tile when you click on any rendition name under the Image URL field the delivery image URL was specified and had to change it with the URL specified in the image that sorted my issueenter image description here

0

You should also give read access to the underlying file (M.File). See the attached image. Since both are needed in order to get access to the actual file. I often combine them both like this.

Read example for M.Asset & M.File

1
  • Adding Read access to M.File did not resolve the issue. I tried both a separate right, and combied as shown above, though I omitted "ViewNotWatermarked", as my goal is to display the watermarked preview. May 10, 2022 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.