0

We have a Sitecore form on our website. We created the custom submit action to identify contact based on the email ID following the link.

After creating the custom submit action and mapping it to the form. Once the user submits the form the new record is created the experience profile. but user interaction and last duration time are not displayed in the dashboard.

FYI, we have enabled the following in this file sc.Xdb.Collection.IndexerSettings.xml

 <IndexPIISensitiveData>true</IndexPIISensitiveData>
  <IndexAnonymousContactData>true</IndexAnonymousContactData>

There is no data in the interaction table [xdbsc_Xdb.Collection.Shard0].[xdb_collection].[Interactions]

why the user activity is not displaying in the dashboard?

5
  • What is the role of the instance you are submitting the form on? (Ie contentmanagement, contentdelivery or standalone) Aug 8, 2023 at 11:51
  • The role we have tried content management and standalone Aug 8, 2023 at 12:36
  • Tracking is disabled by default on content management instance. Please try submitting from content delivery instance, then either abandon session or wait timeout, then check to see if data arrives I'm interactions table. Also, you can check siteore/admin/showconfig.aspx to see if tracking is somehow disabled Aug 8, 2023 at 13:11
  • I tried to closing the browser and open again and visit the page, submit the form Aug 8, 2023 at 13:34
  • Did you try from contentdelivery instance? Also what was value of Xdb.Tracking.Enabled in showconfig.aspx? Aug 8, 2023 at 14:07

1 Answer 1

0

It looks like an issue with xDB data. Contact or interaction data does not appear in the collection database until after the session has timed out.

You can refer below steps to validate interactions appear correctly in the collection database.

  1. Start InPrivate browsing in Firefox or Chrome and visit a few web pages on the site.
  2. Find the SC_ANALYTICS_GLOBAL_COOKIE cookie and save the value preceding the pipe. For example, retrieve the value "169e920af41d4960ad9eff4d3260f8d9" from the following cookie "169e920af41d4960ad9eff4d3260f8d9|True".
  3. Request the Abandon.aspx page to flush the data immediately or close the window and wait for the end of the session.
  4. Consider one of the following options:
    • For Sitecore XP 9.0.0 or higher, when SQL provider is used, connect to shard databases and run the following query against each of them:

      SELECT LastKnownContactId  FROM [xdb_collection].[DeviceProfiles]
      WHERE DeviceProfileId = '169e920a-f41d-4960-ad9e-ff4d3260f8d9'
      --id retrieved from Cookie should go here. Add dashes to make the value correct GUID.
      

      One of the databases must contain the LastKnownContactId. Use it to retrieve the interaction (it will be in one of the shard databases):

      SELECT * FROM [xdb_collection].[Interactions] 
      WHERE ContactId = '138E219A-0A5A-0000-0000-05D0EB074C6D'
      -- where 138E219A-0A5A-0000-0000-05D0EB074C6D is the copied LastKnownContactId value.
      

Note: Check this article if you are using a different Sitecore version.

Once your collection database is populated with interaction and still issue persists you can try Rebuild the reporting database

Hope it helps!

2
  • I have checked in the table SELECT LastKnownContactId FROM [xdb_collection].[DeviceProfiles] but there is not data in this table. Aug 8, 2023 at 13:01
  • Try to troubleshoot with steps provided in scenario 1 support.sitecore.com/… Aug 8, 2023 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.