I have installed the Vannila instance of Sitecore 10.2 and added a standard MVC Layout with @Html.Sitecore().VisitorIdentification() and created one sample form with First name, Last Name, and Email after that mapped with the page and assign submit action.

Now, Visited the page and submitted the form. The data is saved on the form database.

1. I have enabled Anonymous as a true
2. Enabled PIISensitive data as a true
3. Submitted the form and close the browser for session close.

There is no interaction is displaying in the expericence profile and Last visit duration.

enter image description here

  • Did you check that the Xdb.Tracking.Enabled is set to true in the App_Config\Sitecore\Marketing.xDB\Sitecore.Xdb.config configuration file? Aug 10 at 12:17
  • That is already enabled in the file Aug 10 at 12:55
  • Are you doing this on contentmanagement role? If so try standalone or contentdelivery Aug 12 at 21:10
  • I'm using content management role Aug 16 at 14:35

2 Answers 2


I would suggest you check the following things on your solution to make it work.

  • Rebuild All Indexes from Control Panel

  • Build Link Databases

  • Go to your xConnect instance and enable tracking of anonymous users in App_data\Config\sitecore\SearchIndexer\sc.Xdb.Collection.IndexerSettings.xml and App_Data\jobs\continuous\IndexWorker\App_Data\config\sitecore\SearchIndexer\sc.Xdb.Collection.IndexerSettings.xml by updating the below setting to true


I hope this will solve your issue.

  • Did you check these settings? Aug 10 at 13:06
  • I have already enabled all the settings, Now I have rebuild the link database and rebuild all the index then the latest interaction is showing now. I will recheck and confim Aug 10 at 13:32
  • @Rameshkumar Great. Aug 10 at 13:48
  • @Rameshkumar Did it solve your issue? Aug 11 at 6:28
  • No It is not solved. Aug 11 at 6:54

In order to track analytics data to the correct database please check the following:

  • check whether the "collection" connection string is pointed to the right ShardMapManager database;

  • check whether xConnect connection strings on CD instances are pointed to the correct xConnect;

  • check whether the correct server name and database name is set in the following tables:


If everything is set correctly please try to restart CD and xConnect instances and check whether the issue is reproducible afterwards.

The absence of data in the Experience Profile could be due to the following reasons:

  1. There are no identified contacts in Shards. By default indexing of anonymous contacts is disabled. In order to enable it please refer to the following article: https://doc.sitecore.com/xp/en/developers/103/sitecore-experience-platform/enable-indexing-of-anonymous-contacts-in-the-xdb-index.html
  2. In case there are identified contacts in Shards and you do not want to enable indexing of anonymous contacts in order to see data in Exp Profile please perform the rebuild of the xdb index: https://doc.sitecore.com/xp/en/developers/103/sitecore-experience-platform/rebuild-the-xdb-index-in-solr.html

Please be sure that IndexPIISensitiveData setting in the sc.Xdb.Collection.IndexerSettings.xml file is true in the xdbsearch and in the xdbsearchworker instances. Please run rebuild on your xdbsearchworker instance using .\Sitecore.XConnectSearchIndexer.exe -rr command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.