0

when I try to load my sitecore website homepage it shows me following error, where i see the default site context being picked is "scheduler" not "Website" which should be the default.

enter image description here

 <sites>
<site name="shell" virtualFolder="/sitecore/shell" physicalFolder="/sitecore/shell" rootPath="/sitecore/content" startItem="/home" language="en" database="core" domain="sitecore" loginPage="/sitecore/login" content="master" contentStartItem="/Home" enableWorkflow="true" enableTracking="false" analyticsDefinitions="content" xmlControlPage="/sitecore/shell/default.aspx" browserTitle="Sitecore" htmlCacheSize="10MB" registryCacheSize="15MB" viewStateCacheSize="1MB" xslCacheSize="25MB" disableBrowserCaching="true"/>
<site name="login" virtualFolder="/sitecore/login" physicalFolder="/sitecore/login" enableTracking="false" database="core" domain="sitecore" disableXmlControls="true"/>
<site name="admin" virtualFolder="/sitecore/admin" physicalFolder="/sitecore/admin" enableTracking="false" enableWorkflow="true" domain="sitecore" loginPage="/sitecore/admin/login.aspx"/>
<site name="service" enableTracking="false" virtualFolder="/sitecore/service" physicalFolder="/sitecore/service"/>
<site name="modules_shell" virtualFolder="/sitecore modules/shell" physicalFolder="/sitecore modules/shell" rootPath="/sitecore/content" startItem="/home" language="en" database="core" domain="sitecore" content="master" enableTracking="false" enableWorkflow="true"/>
<site name="modules_website" virtualFolder="/sitecore modules/web" physicalFolder="/sitecore modules/web" rootPath="/sitecore/content" startItem="/home" language="en" database="web" domain="extranet" allowDebug="true" cacheHtml="true"/>
<site name="website" enableTracking="false" virtualFolder="<my virtualFolder>" physicalFolder="/" rootPath="/sitecore/content" startItem="/home" database="web" domain="extranet" allowDebug="true" cacheHtml="true" htmlCacheSize="50MB" registryCacheSize="0" viewStateCacheSize="0" xslCacheSize="25MB" filteredItemsCacheSize="10MB" enablePreview="true" enableWebEdit="true" enableDebugger="true" disableClientData="false" cacheRenderingParameters="true" renderingParametersCacheSize="10MB"/>
<site name="scheduler" enableTracking="false" domain="sitecore"/>
<site name="system" enableTracking="false" domain="sitecore"/>
<site name="publisher" domain="sitecore" enableTracking="false" enableWorkflow="true"/>

Please help me understand why Sitecore is picking Scheduler site context instead of "website".

  • 2
    You cannot install Sitecore in a virtual folder. Change the virtualFolder property of "website" to be /; point IIS to the /Website folder of your Sitecore installation, and map any local hostname on the IIS Site definition. See chapter 4.3 in this (slightly outdated) walkthrough. sdn.sitecore.net/upload/sitecore6/65/… – Mark Cassidy Sep 20 '17 at 14:35
3

As Mark mention in his comment, set virtualFolder="" value to virtualFolder="/" The reason for your context site is not resolving to "website" is the virtualFolder setting you have.

When you request http://hostname/ , Sitecore will not match to "website" since your "website" site definition have virtualFolder set to "

If you want to add or adjust site definition, its advice not to adjust the default "website" site definition. Add your own site definition before "website" site definition and do the adjustments to that.

0

I think you miss the hostname attribute.

Sitecore determines the site context based on the incoming URL and the following two attributes hostName and virtualFolder.

check this - https://sdn.sitecore.net/Articles/Administration/Configuring%20Multiple%20Sites/Configuring%20Sites%20in%20web,-d-,config%20File.aspx

check multi site configuration also How do I configure Sitecore to serve multiple sites?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.