9

I Installed Sitecore 9 XP1 with Separate CD and CM servers.

I am getting the below error in CD:

Unexpected character encountered while parsing value: <. Path '', line 0, position 0
31260 12:55:45 ERROR Cannot start analytics Tracker
Exception: Newtonsoft.Json.JsonReaderException
Message: Unexpected character encountered while parsing value: <. Path '', line 0, position 0.
Source: Sitecore.Xdb.Common.Web
8
  • Validate that you have not typo'ed the Analytics.ClusterName setting. May 16, 2018 at 19:52
  • 2
    Did you manage to find the root cause? I'm running into same error on CM servers. Nov 8, 2018 at 12:41
  • 1
    I am getting the same error. And I did verify there is no typo for the Analytics.ClusterName setting. I did notice that the value has "mysite.local.com", and I removed "http://". @PeteNavarra
    – Hetal Dave
    Nov 12, 2018 at 21:03
  • ClusterName must be resolvable on dns on all servers. Also, if on Sitecore 9, Tracker also makes a connection to xConnect, and if xConnect isn't working neither will Tracker. Nov 12, 2018 at 21:43
  • I believe the below solution would help to resolve issues. sitecore.stackexchange.com/questions/16937/… sitecore.stackexchange.com/questions/8561/… Thanks! Feb 21, 2019 at 15:39

2 Answers 2

1

The error message you're encountering suggests an issue with parsing a JSON response, and it appears that the response received is not a valid JSON format. This issue is commonly associated with problems in communication between the Content Delivery (CD) server and the Content Management (CM) server in a Sitecore XP1 setup.

Here are some steps you can take to troubleshoot and resolve the issue:

Check Connection Strings:

Ensure that the connection strings in the CD server's ConnectionStrings.config file point to the correct databases on the CM server.

Check xConnect Configuration:

Verify the sitecore/xconnect section in your CD server's App_Config includes the correct xConnect URLs and settings.

Check xConnect Service:

Ensure that the xConnect service on the xConnect server (CM server in your case) is running and accessible from the CD server. You can test the xConnect service URL directly in a browser.

Check Logs:

Review the logs on both CD and CM servers for any additional error messages or warnings. The CM server logs might provide more details about the issue.

Check xDB Initialization:

Verify that xDB is initialized properly on the CM server. Check the xDB configuration files and ensure that the databases are created and accessible.

Check for Sitecore Patches and Updates:

Make sure that your Sitecore installation includes the latest patches and updates. Sitecore releases updates that may address known issues.

Review Custom Code:

If you have custom code, pipelines, or services in your solution, review them for potential issues that might interfere with xConnect communication.

By systematically checking these aspects, you should be able to identify and resolve the issue causing the unexpected character parsing error.

0

I had this issue again. And the actual problem is that my reference data in XP scaled set up. I find my reference data service URL is not Once I fix that. It worked again. enter image description here

1
  • 1
    I would consider replacing the hard-to-read image with a code block that highlights what you're trying to suggest as the answer to this question. Jul 18, 2023 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.