We are trying to install Sitecore 9.0.1 rev 171219 (XP0) on-premise.

Everything goes fine until it tries to create Sitecore.Messaging Database. As the installation have already created MarketingAutomation, Processing.Pools and ReferenceData Databases successfully in SQL server. But when it is creating Sitecore.Messaging Database, throwing below exception:

Info: Opening SQL Connection with connection string 'data source=mysqlserver;initial catalog=Sitecore.Messaging;user id=sitecoresvc;pooling=False'. The 'transacted' setting for this connection is 'False'.
Error Code: ERROR_SQL_EXECUTION_FAILURE
More Information: An error occurred during execution of the database script. The error occurred between the following lines of the script: "9" and "12". The verbose log might have more information about the error. The command started with the following:
"CREATE USER [messaginguser] WITH PASSWORD = '123"
 Password validation failed. The password does not meet Windows policy requirements because it is too short. 

Looks like while creating this Database it is not respecting the password provided in ps1 file parameter but picking the default one.

Any help is much appreciated!!!

up vote 3 down vote accepted

Your database is complaining that the password you specified for the messaging user (SqlMessagingPassword parameter) is too "simple". SQL will enforce you to use stronger passwords for your users. Just set the password in that parameter in the json file to something better.

Check the other passwords in the json file as well before retrying (and do a cleanup first).

  • The only password I provided is in the ps file parameter which is according to our sql server policies. That is what it is able to create other database. Do I need to provide separate password for MessagingUser? Also where can I find the steps for cleanup? – Amitabh Vyas May 31 at 10:20
  • 1
    You need to configure the json files for the installation. This pwd will be set in the Sitecore-XP0.json file. For cleanup - there is no real guide I think but I assume in your case deleting the already installed databases would be enough. – Gatogordo May 31 at 11:14
  • Do you mean I need to update all the "Default Passwords" mentioned in the json files and provide a password matching my SQL password policies ? – Amitabh Vyas May 31 at 16:17
  • 1
    Yes, you need to set all parameters in the json files. – Gatogordo May 31 at 17:00
  • Just for future reference I replaced all the default Test12345 and 12345 passwords mentioned in xconnect-xp0.json and sitecore-XP0.json file with a password according to my SQL server password policies. You can also pass those passwords as a parameter from you PS1 file. – Amitabh Vyas Jun 8 at 15:06

You have to set you password of sql database of your used as per alphanumeric password policy. Your password should be like "password@123" which is a strong type password.

just edit your user in sql , change the password and retry installing SIF again. also make sure you use SQL 2016 SP1 and above for sitecore 9.

You can generate a strong password using a SIX module. This module has a config function to generate a password:

"Variables": {
    "SitecoreAdminPassword": "[password('8')]",
    "SqlAdminPassword": "[password('16')]",
  },

Passwords in Powershell scripts must be inside '' not "". enter image description here

Module SitecoreInstallAzure additionaly can store secrets in Azure KeyVault.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.