1

Background: I am trying to install Sitecore 9.1 XP0 developer topology on my local machine, however, the SIF install fails at task 65 out of 88 with the error message Installation error: Failed to start service 'Sitecore Marketing Automation Engine.

One thing I noticed, which could be part of the reason for the error, is the fact that the Sitecore xConnect website is not working. It does not return an HTTP error, it simply does not load, but returns a "This site can’t be reached" - ERR_SPDY_PROTOCOL_ERROR (in Chrome) and asks if I want to open Visual Studio to debug the error.

Things I have tried: I re-tried a fresh install, changing site prefix, alot of times (50+). Same result each time.

I tried specifying security rights for Local service/IUSR/IIS_IUSRS for the resource folder, without luck.

I verified that all the connectionStrings to the xConnect database are correct and database logins works

I removed all previous installations of SIF and only installed SIF 2.0.0

I checked the eventlog, and all I can find is:

Faulting application name: w3wp.exe, version: 10.0.15063.0, time stamp: 0xf0e19ef5 Faulting module name: KERNELBASE.dll, version: 10.0.15063.1478, time stamp: 0x7789680f

I checked the log for the xConnect website, and it seems that the website starts, but then immediately crashes. The log states: 2019-03-02 20:36:39.797 +01:00 [Information] XConnect Test Host Application Start, Machine: "[MACHINE-NAME]", Site: "PREFIX.xconnect", AppId: "/LM/W3SVC/15/ROOT"

The log for the xConnect automation service states:

2019-03-02 20:36:51.343 +01:00 [Error] Error initializing XConnect client. System.AggregateException: One or more errors occurred. ---> Sitecore.XConnect.XdbCollectionUnavailableException: An error occurred while sending the request. ---> System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host at System.Net.Sockets.Socket.EndReceive(IAsyncResult asyncResult) at System.Net.Sockets.NetworkStream.EndRead(IAsyncResult asyncResult) --- End of inner exception stack trace --- at System.Net.Security._SslStream.EndRead(IAsyncResult asyncResult)

The kicker: I tried the exact same install on my private pc and everything works as intended.

What could cause the SIF install to not be able to start the service 'Sitecore marketing Automation Engine' and is that in any way related to the fact that the xConnect website does not work?

  • Have you installed Sitecore before on the computer? I have experienced strange things when running SIF multiple times. I would recommend using a VM if you are not already. – Gravypower Mar 2 at 0:39
  • Yes I had SIF installed before so it could maybe be the cause. I however also tried the install on one of the company VMs and had the same issues. When I tried on my PC at home everything worked just fine but on my work PC nothing works. – Hos Mar 2 at 7:09
  • maybe its a group policy causing the issues, have a chat to IT and ask if there is anything that will cause certs not to work correctly – Gravypower Mar 3 at 2:41
  • Is there a way for me to confirm that it is a group policy that is causing the issue? So I have something concrete to tell the IT department. Because the certs looks OK when you browse it in mmc – Hos Mar 3 at 6:15
  • I am not familiar with it sorry, if I was going to take a guess it would be something to do with the self-signed cert. – Gravypower Mar 3 at 19:59
2

I suspect you are running into a certificate issue where you have self signed certificates in the Trusted Root that need to be removed. Check out this blog post. https://getfishtank.ca/en/blog/sitecore-9-xconnect-status-403-forbidden-certificate-error

The main point of the post is to remove the non-self signed certificates in your root.

Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject} 

This will list you certificates that need to be removed. This command should return no results, if everything is OK.

Now you need to remove them. The following powershell will remove the offending certificates.

Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject} | Move-Item -Destination Cert:\LocalMachine\CA 
  • Unfortunately that command does not return anything. Thanks for the suggestion! – Hos Mar 6 at 10:48
0

In the end what worked for me was installing all the latest Windows updates. However, since I am working on an enterprise PC it was not enough to just "Check for updates" since that did not check outside the company for updates. I had to use "Check online for updates from Microsoft".

These are the updates that were installed:

  • KB4293803 - GDR 2002 for Microsoft SQL Server Browser
  • KB4293803 - GDR 2002 for Microsoft SQL Server 2017 (64 bit)
  • KB3095681 - Update for Microsoft Visual Studio 2015
  • KB3165756 - Update for Microsoft Visual Studio 2015
  • KB3022398 - Visual Studio 2015 Update 3
  • KB4293803 - GDR 2002 for Microsoft SQL Server VSS Writer (64 bit)
  • KB4485449 - Security Update for Microsoft Windows
  • KB4487029 - Update for Microsoft Windows
  • KB2504637 - Update for (NO name specified)

You can probably disregard the updates for Visual Studio, but they have been added to the list for the sake of completeness.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.