1

Following the JSS quick start instructions I do:

npm install -g @sitecore-jss/sitecore-jss-cli
jss create my-first-jss-app react
cd my-first-jss-app
jss start

Next step I go to is to run JSS Setup before this I have gone through all prerequisite steps shown on the JSS Server Setup page.

  1. Installed Server Components
  2. Verified server components installed and worked by visiting http://your-sitecore-instance/sitecore/api/layout/render/jss?item=/&sc_apikey=TEST

Now I go into my newly created app folder for my-first-jss-app. Within this I load up a bash CLI in admin mode I run jss setup. To get:

npm[30856]: src\node_file.cc:1599: Assertion `args[1]->IsInt32()' failed.
 1: 00007FF776FA0EFA v8::internal::GCIdleTimeHandler::GCIdleTimeHandler+4810
 2: 00007FF776F7A296 node::MakeCallback+4518
 3: 00007FF776F7A34F node::MakeCallback+4703
 4: 00007FF776F3F413 uv_loop_fork+34643
 5: 00007FF7777AADD2 v8::internal::OptimizingCompileDispatcher::Unblock+60562
 6: 00007FF7777AC26D v8::internal::OptimizingCompileDispatcher::Unblock+65837
 7: 00007FF7777AB2C9 v8::internal::OptimizingCompileDispatcher::Unblock+61833
 8: 00007FF7777AB1AB v8::internal::OptimizingCompileDispatcher::Unblock+61547
 9: 000003BD8BBDC5C1

Why is this going wrong?

Debugging this I confirm the following:-

  • CLI is in admin mode
  • Node version: v10.15.1
  • NPM version: 6.4.1
  • JSS version: 11.0.2
  • Using nvm to manage version of node used
  • Unable to so far get verbose logs
  • Removing lock file and node modules folder and running npm install doesn't fix the issue

Using nvm to install and change to second version of Node. In my case 8.15.0 produces a different result worth mentioning. jss setup just hangs.

1

There are multiple steps to try, some I have mentioned in the question. If you run in the similar issues I recommend doing the following to help get to bottom of it.

  • Use a tool like nvm to help switch between versions of node and npm module on your machine quickly and easily.
  • Try node at x64 and x86 bit architecture
  • Try different versions of node and npm
  • At your own risk, delete node_modules folder and/or remove package.json.lock file in your created app folder and hit npm install
  • Try it out on a different machine

However before you do any of the above, I recommend trying a different CLI.

  • Git Bash CLI was the culprit here, why I do not know.
  • I moved over to powershell CLI it worked I now however gone back to another old favorite of mine cmder where it works just fine as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.