0

I'm trying to run this simple sitecore docker demo project https://github.com/Sitecore/docker-demo/tree/develop/sitecore/9.0.1%20rev.%20171219%20XM1/VS2017/SimpleSample

However I keep getting this error:

1>Step 9/13 : RUN Rename-Item -Path $env:SITEPATH -NewName $env:DEFAULTWEBSITENAME; New-Item -Path $env:SITEPATH -ItemType Directory | Out-Null; 1> ---> Running in 8b683e2bef08 1>[91mRename-Item : Cannot bind argument to parameter 'Path' because it is null.

I can't find $env:SITEPATH being set in solution. Feels like Im missing some step here but can't figure out.

Looks like this issue has been raised but never answered: https://github.com/Sitecore/docker-demo/issues/12

| improve this question | | | | |
  • I get the same error using 9.0.180604, I am trying to setup a visual studio project with the standalone image. I get the same error with xm1.cm Any help would be appreciated. – John Banks Oct 13 '19 at 18:12
1

It turns out that I was using wrong sitecore version image.

$env:SITEPATH is defined in the base image.

All variables defined in a base image are available to the images (containers) that are on base image.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.