0

I've set up a blank Sitecore 9.1.1 XP instance and tried to get JSS up and running.

I've installed the Sitecore JavaScript Services Server for Sitecore 9.1.1 XP package and 11.0.2 sitecore-jss-cli. I'm using the React sample app (https://github.com/Sitecore/jss/tree/dev/samples/react) and this is running correctly in disconnected mode.

The issue is when I try to deploy the react code to Sitecore using jss deploy app -c -d; I'm getting a 404 from the import service.

My layout service and API key are returning a JSON response as expected, so not sure where else to look.

0

I've resolved this thanks to this blog, i had the import endpoint in my scjssconfig.json setup to http; setting this to https then gave me a certificate error. Setting my certificate to be trusted solved it as per the steps here:

https://www.codealamodeblog.com/Sitecore/JavaScript-Services/jss-troubleshooting-connecting-to-sitecore/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.