2

Fresh new Sitecore XP 9.2 + JSS 12.0 and trying to deploy an OOTB react JSS app.

The ApiKey is created (with two * for test only).

The Layout Service is responding on /sitecore/api/layout/render/jss?item=/&sc_apikey={...} properly with {"sitecore":{"context":{"pageEditing":false,"site":{"name":"website"}....

jss setup and jss deploy config worked perfectly.

When I run jss deploy app -c -d I have this error:

JSS is manifest packaging my-jss-app to ./sitecore/package...
Adding data/media/files/jss.pdf
Adding data/media/img/jss_logo.png
Adding data/media/img/sc_logo.png
Adding sitecore-import.json
Wrote sitecore\package\my-jss-app.1566916961828.manifest.zip
Sending package sitecore\package\my-jss-app.1566916961828.manifest.zip to http://jss-sc920-2.sc/sitecore/api/import...
Unexpected response from import service:
Status message: Found
Body: <html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="/sitecore/service/notfound.aspx?item=%2fsitecore%2fapi%2fimport&amp;user=extranet%5cAnonymous&amp;site=website">here</a>.</h2>
</body></html>

Really would appreciate any help.

Note: I'm already using all latest version so Import process fails : "Unexpected response from import service: Status message: Found" doesn't apply.

1

I had also faced similar situation , in my case following 3 points needed to be changed :

1) Make sure your Sitecore License has JSS license included , you can check this from licenses

enter image description here enter image description here

2) Make sure you have installed the JSS Server Components Sitecore package through installation wizard as per your Sitecore instance version from following link. https://dev.sitecore.net/Downloads/Sitecore_JavaScript_Services.aspx

3) Make sure that when JSS setup command is executed and you are prompted to provide option , provide the app name of your jss app in Sitecore hostname , similarly Sitecore Service URL as shown below. Of course new IIS site binding and host entry is also required. Also make sure no VPN or proxy is affecting your copying.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.