0

I'm using Web Forms for Marketers 9.0 in my Sitecore instance 9.0.1. I have to develop a form with CREATE ITEM save action. The form contains fields like Name, Profile image, and a few other fields. The form works fine by creating the item where all the fields are mapped except the image. The profile image field is empty. But the image is created in media library.

This image has to be mapped to the item's image field.

How can I resolve this issue? Any help would be appreciated.

  • 1
    Post your current code. Otherwise it will be quite hard to help you – Marek Musielak Jan 11 at 11:40
  • The Create Item Save Action in WFFM is ootb, there is no code to post. Its just configuration and a mapping exercise from WFFM field to Template field. – jammykam Jan 12 at 17:46
1

This issue is a known issue described in this Sitecore Knowledge Base article: https://kb.sitecore.net/articles/091652

You can request a patch for your version of the WFFM module to Sitecore Support. It seems that this fix was never included in future versions of the module. I checked the code of the Sitecore.Form.Submit.CreateItem class in all three versions of the WFFM 9.0 module (Initial Release, Update-1 and Update-2) and all three versions don't have the fix developed in the Support patch.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.