0

I am working with Sitecore 9 update 1, I have created a Goal, deployed and published it. After that, I have applied goal on Home page and other Sitecore pages, the document I followed https://doc.sitecore.com/users/82/sitecore-experience-platform/en/create-and-deploy-a-goal.html. I browsed these page many times and closed the browser sessions to be written in XDb but i could not find any Goals returned in Experience Analytics.

enter image description here

Also No thing related to my Goal exist in [Xdb.Collection.Shard0].[xdb_collection].[Interactions] table in DataBase. I do not know where is the problem, Is there any configuration should be done first. or The Goals takes time to be written in XDB ??

0

Make sure you have published the goals and also published Home page and other pages where you associated the goals.

You need to make sure that you have enabled indexing of anonymous contacts in the appropriate config file as given here and then set the default session timeout to 1 min as given here. After doing these things, make the visit to a page (that has goal associated to it) in incognito mode, close the browser window. After 1 min, you should definitely see that data in Experience Analytics and also in Experience Profile (a new row will be added with last interaction column value as 1 min). Clicking on the Anonymous user should show the goals that were triggered in the visit

| improve this answer | |
  • I published the pages where I associated the goals already, and the indexing of anonymous contacts is enabled already, but when I tried with logged in user the goals comes, so what do you think about the anonymous contacts that not come even if the indexing of anonymous contacts is already enabled. should I rebuild the xDB search index again ? – shimaa elsayed Aug 6 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.