0

I have installed vanilla sitecore commerce version 9.3 on my local machine. I have created a new environment "CustomEnvironment" and created a new catalog "client_catalog" and created "client_pricebook".

Now i am trying to associate the pricebook to the catalog by by associating catalog in pricebook section. But i am getting an error "Catalog name already in use"

I have tried to clean environment,bootstrap environment and initialize environment as suggested in sitecore documentation but it is still showing the same error.

Any suggestions?

enter image description here

2

This might have happened when trying to add same catalog name which was deleted manually from catalogs section of merchandising tool. To resolve the error, you can restore the database to a new database (default installation Sitecore commerce databases) or Follow the process below to resolve the issue

  1. In Postman, Ensure default content paths API Call
  2. In Postman, Clean environment Habitat Authoring and custom environemnts API call
  3. Redis cache might not have been cleared and it still contains association of old catalog data. As clean environment only clears the cache in memory, run Clear redis cache by running “redis-cli -h localhost FLUSHALL”.
  4. Bootstrap the Custom environment.
  5. In Postman, initialize habitat environment now will clear the and custom environment initialize is not required.
  6. Recycle the application pool

After following the steps above, associate the pricebook now with custom catalog.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.