0

I'm not sure my title is ideal, so I am open to suggestions because I wasn't sure how to phrase it.

I am trying to create a Let's Encrypt cert using CertBot and it creates a file inside the /.well-known/ directory. The problem is that Sitecore tried to process the URL instead of letting the file be loaded in the browser.

How do I tell Sitecore to ignore any URL that starts with "/.well-known/" and just let IIS handle it as it would normally?

I tried IgnoreUrlPrefixes

<setting name="IgnoreUrlPrefixes" value="/trace.axd|/webresource.axd|/sitecore/shell/Controls/Rich Text Editor/Telerik.Web.UI.DialogHandler.aspx|/sitecore/shell/applications/content manager/telerik.web.ui.dialoghandler.aspx|/sitecore/shell/Controls/Rich Text Editor/Telerik.Web.UI.SpellCheckHandler.axd|/Telerik.Web.UI.WebResource.axd|/sitecore/admin/upgrade/|/layouts/testing|/sitecore/service/xdb/disabled.aspx|/.well-known/" />
4
  • 1
    Have you tried IgnoreUrlPrefixes setting? Dec 11 '20 at 15:09
  • I did (I meant to mention that): <setting name="IgnoreUrlPrefixes" value="/trace.axd|/webresource.axd|/sitecore/shell/Controls/Rich Text Editor/Telerik.Web.UI.DialogHandler.aspx|/sitecore/shell/applications/content manager/telerik.web.ui.dialoghandler.aspx|/sitecore/shell/Controls/Rich Text Editor/Telerik.Web.UI.SpellCheckHandler.axd|/Telerik.Web.UI.WebResource.axd|/sitecore/admin/upgrade/|/layouts/testing|/sitecore/service/xdb/disabled.aspx|/.well-known/" />
    – Michael
    Dec 11 '20 at 15:31
  • What happens when you used IgnoreUrlPrefixes? Dec 11 '20 at 17:54
  • Nothing. I placed a test html file into the .well-known folder and I got 404 as before using the setting.
    – Michael
    Dec 14 '20 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.