0

I'm trying to install Sitecore 9.3.0 & Sitecore 10.0.0 in my local machine and both the installations fail with the same error.

enter image description here

enter image description here

Tried with both the set.exe & the SIM tool. Did not change any configurations.

Searching for this error on SSE says, it could due to the license. But this is a valid one provided by my company and others were able to install without any issues with the same one.

I tried installing it in the C:Drive and then the D:\ drive too. It fails at the final step...after the Databases are created. Solr installation goes fine too. I browse the solr url in the browser and it opens fine.

This is the error I see in the log after installing with SIM.

> [-------------------- PrepareCores [1] : Copy
> --------------------------------] Install-SitecoreConfiguration : Cannot validate argument on parameter 'Source'. The " Test-Path $_ "
> validation script  for the argument with value
> "D:\Solr840\server\solr\configsets\_default\*" did not return a result
> of True. Determine  why the validation script failed, and then try the
> command again. At line:12 char:1
> + Install-SitecoreConfiguration @installParams *>&1 | Tee-Object xconne ...
> + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
> + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration
6
  • 1
    Can you try to start the service manually and check the logs afterwards to check what errors you are getting? You can also verify if you have the correct license in the folder \App_data\jobs\continuous\IndexWorker\App_data – Cristi Vulturar Mar 8 at 8:12
  • @CristiVulturar. Manually starting shows the error that unable to start. Can u please tell me where should I check these logs. – Qwerty Mar 8 at 10:35
  • Check the Windows Event Log, when services fail it logs a message in the Application Log. Also make sure to check the indexworker logs aswell in \App_Data\jobs\continuous\IndexWorker\App_Data\Logs\ – Cristi Vulturar Mar 8 at 12:25
  • 1
    Check the windows event viewer to see what error you get. that will be a good start to resolve this issue. – Mahesh Raghupathi Mar 8 at 22:49
  • 1
    or delete the current sitecore instance and start again from scratch, you can follow the steps in this blog to delete your instance maheshraghupathi.wordpress.com/2021/03/03/… – Mahesh Raghupathi Mar 8 at 22:50
2

The error seems to be related to Solr Cores are not copied properly where Solr was installed. Can you check the place where Solr was installed does it contains Solr cores. If not, then Index Worker is not able to work without them, which would explain that service cannot start. I recommend running setup as administrator and disable anti-virus software. I had similar issues and I got them working by disabling anti-virus and running it as administrator.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.