1

I am trying to setup publishing module (ver 4.3) for my sitecore 10.0 application, everything has been done based on manual/script steps in document. Like configure connection string, creating IIS site, adding host entry, application pool setup etc. But seems there is some issue due to which not able browse the site.

Thus when browse url: http://sitecore.publishing/api/publishing/operations/status, it gave error: enter image description here

Note: My development site is on https but I am configuring my publishing service on http. enter image description here Please suggest if i am missing something/

When tried to load service from powershell, it gave error: enter image description here

After above issue gets resolve getting Permission issue: enter image description here I have make sure that Everyone has full right on the folder to get started but then also no luck.enter image description here

Error in log :

[Fatal] Unable to start Kestrel.
Microsoft.AspNetCore.Server.Kestrel.Transport.Libuv.Internal.Networking.UvException: Error -4092 EACCES permission denied
   at Microsoft.AspNetCore.Server.Kestrel.Transport.Libuv.Internal.Networking.LibuvFunctions.ThrowError(Int32 statusCode)
4
  • Could you please share what you are getting in the logs? also look like you are running a https URL Sep 19, 2022 at 14:05
  • It don't enter this issue in log, in logs i only have command details. Also running it on http, not sure why it is showing Not Secure label
    – Rinku Jain
    Sep 19, 2022 at 14:11
  • Now getting Access Denied error, details are given description, due to this still not able to use pub service
    – Rinku Jain
    Sep 20, 2022 at 8:39
  • After some security turn on/off and restart, Hyper V turn on/off, Finally my Publishing service is started working, although i am getting that permission error in powershell, but able to browse now . Not able to select Mahendra and Sumit both answer, but upvoted them, as they helped to reach to my solution
    – Rinku Jain
    Sep 20, 2022 at 13:16

2 Answers 2

1

Try running it through PowerShell script like this.

.\Sitecore.Framework.Publishing.Host --urls 'http://sc910.publishing:5000' -environment Development

It will give you the error on the console.

Also check this article below and seems like this is a similar kind of issue.

https://sitecorefootsteps.blogspot.com/2019/12/sitecore-publishing-service-410-setup.html

Might resolve your issue.

Thanks

6
  • This link talk about same issue, but in my case this dll is already unlock
    – Rinku Jain
    Sep 19, 2022 at 14:36
  • Ok by running the PowerShell command did you get any logs? Sep 19, 2022 at 14:38
  • i have added error details in description
    – Rinku Jain
    Sep 19, 2022 at 15:39
  • @RinkuJain Your error looks the same as given in the article I have shared. Can you also try this? " I've seen this trip up quite a few people now. Another alternative to hunting the specific DLL would be to Unblock the Publishing Service zip file after download " Sep 19, 2022 at 16:08
  • as shown in image at description, mentioned dll is already unBlock and the folder too when i had downloaded it.
    – Rinku Jain
    Sep 20, 2022 at 6:36
1

Your publishing service is not able to read the "Serilog.AspNetCore.dll" which comes with the Publishing service installation. You need to open the properties of "Serilog.AspNetCore.dll" and click the "Unblock" button in the popup window. Looks like some typo or other issue in the article but it is not "unlock", it is "unblock" and you need to check this (not uncheck) -

enter image description here

2
  • as shown in image at description, mentioned dll is already unBlock and also the folder when i had downloaded it.
    – Rinku Jain
    Sep 20, 2022 at 6:37
  • please refer updated detail for error
    – Rinku Jain
    Sep 20, 2022 at 10:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.