0

I am trying to install Publishing Service Module 9.1 in Sitecore and I am getting the below error:

enter image description here

The installation failed.

One or more exceptions occurred while processing the subscribers to the 'packageinstall:items:ended' event.

For more information see the Sitecore log.

Try one of the following options:

Retry the installation

Please provide some insights on the same if anyone has faced this issue before.

4
  • 1
    Did you check the Sitecore logs for details information? May 25, 2023 at 12:19
  • And what Sitecore version you are using? May 25, 2023 at 12:22
  • 1 . check for any custom code in this pipeline which may cause this issue. 2. Check the sitecore log if got anything 3. if nothing works for time being comment this event process in config and once installation is done then uncomment it, as sometime due to some weird reason we may get this kind of issue.
    – Rinku Jain
    May 29, 2023 at 6:14
  • As mentioned previously, remove any custom handlers such as processors running on item:saved etc. If you have such code, it's quite common that package installs fails. If it works by removing such processors, that's also an indication that the processors needs to be narrowed down to only perform specific tasks on specific items, which will both increase performance and avoid other potential issues in Sitecore as well.
    – mikaelnet
    May 29, 2023 at 10:25

1 Answer 1

0

Could you please share the sitecore logs for more details? This issue is probably due to the following reasons:

  1. It might be corrupted config file in your Include folder when failed to install one package.Suggest reinstall it with official Sitecore Publishing Service Module Installation and Configuration Guide.
  2. Invalid credential sometimes lead to this issue as well.Please make sure all your other applications are with valid credentials.

If it still fails,try the following one to check if it works for you.

  1. Comment out this handler during installation,some code like <event name="packageinstall:items:ended"> ...</event> and install the package again.
  2. And Reinstall the package again.
  3. After that,execute index rebuild after package is installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.