I'm installing a pre-release version 10.1.3.
For this I have installed 10.1.2 using the Graphical setup.
Then placed these files in the root folder of the extracted 10.1.2 files.

- Sitecore 10.1.3 rev. 008034 (DELTA WDP XM1 packages).zip
- Sitecore 10.1.3 rev. 008034 (DELTA WDP XP0 packages).zip
- Sitecore 10.1.3 rev. 008034 (DELTA WDP XP1 packages).zip

In the XP0-SingleDeveloper.json file and set the Update parameter to true.

Now when I execute this command in Powershell Install-SitecoreConfiguration -Path .\XP0-SingleDeveloper.json I see this error:

Install-SitecoreConfiguration : Cannot validate argument on parameter 'DnsName'. The argument is null or empty. Provide an argument that is not null or empty, and then try the command again.
At line:1 char:1
+ Install-SitecoreConfiguration  -Path .\XP0-SingleDeveloper.json
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:07
Invoke-NewSignedCertificateTask : Cannot validate argument on parameter 'DnsName'. The argument is null or empty. Provide an argument that is not null or empty, and then try the command
At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.3.0\Public\Install-SitecoreConfiguration.ps1:641 char:47
+                         & $entry.Task.Command @paramSet | Out-Default
+                                               ~~~~~~~~~
    + CategoryInfo          : InvalidData: (:) [Invoke-NewSignedCertificateTask], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : ParameterArgumentValidationError,Invoke-NewSignedCertificateTask

Also, if this was success, will it create a new instance with v10.1.3 or will it update the existing instance, because I have not changed any other setting in the XP0-SingleDeveloper.json.

  • Did you try this? sitecore.stackexchange.com/questions/15315/… Nov 4, 2022 at 8:13
  • @SumitBhatia Yes I did. It's the same error even after that
    – sukesh
    Nov 4, 2022 at 8:24
  • Whenever I run into such problems, I do a full uninstall and manually check that everything has been uninstalled, so hosts file, IIS, certificates, databases, indexes, etc. I also make sure to run the classic command: Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject} | Move-Item -Destination Cert:\LocalMachine\CA Nov 4, 2022 at 16:12
  • When doing a manual uninstall, also check for any services that need to be deleted. Nov 4, 2022 at 16:18

1 Answer 1


The xp0-SingleDeveloper.json file has a section where it pulls in other config files (namely Sitecore-XP0.json):

"Includes": {
    "SitecoreXP0": {
        "Source": ".\\Sitecore-XP0.json"

Within the Sitecore-XP0.json file, there is a parameter called DnsName, which defaults to using the SiteName parameter (which defaults to 'Sitecore'):

"DnsName" :{
    "Type": "string",
    "Reference": "SiteName",
    "Description": "The dns name of the site."

So it looks like this parameter may not have been set properly. Please review your Sitecore-XP0.json file and confirm SiteName parameter has been set. The value should be the root domain only (i.e. not include http:// prefix). The value used should be resolvable on your local instance.

Alternatively, you can pass in those parameters at the command line. For example:

Install-SitecoreConfiguration -Path .\XP0-SingleDeveloper.json -SiteName your-domain.com

I think you will also need to update the package parameter in relevant config files to point to the new delta packages. So in Sitecore-XP0.json:

"Package": {
    "Type": "string",
    "Description": "The path to the Web Deploy package to deploy.",
    "DefaultValue": ""

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.