7

I need to do a clean test in Sitecore Analytics. I have cleaned all Analytics but if I remount the path Analyser all results are brought back. What is the best way to do this?

migrated from sitecore.meta.stackexchange.com Mar 21 '17 at 21:21

This question came from our discussion, support, and feature requests site for developers and end users of the Sitecore CMS and multichannel marketing software.

7

First Method (recommended):

Install the Analytics Database Manager version 3.0

  • When Analytics Database Manager is installed, access the application from the Sitecore launchpad.
  • Go on the "REMOVE OLD DATA" tab, select the desired options and click start.

Second Method:

  • Delete your MongoDB Databases related to the Sitecore instance.
  • Replace the Reporting Database with a clean copy of the corresponding Sitecore version or use the __DeleteAllReportingData stored procedure in /Programmability/Stored Procedures .

enter image description here

  • Restart your Sitecore Instance.
  • I am not sure if ADM is compatible with Sitecore 8 onwards – Andrey Bobrov Mar 22 '17 at 7:46
  • I am currently using the version 3.0 without issues on 8.2 rev. 161221 – Frédérick Fournel Mar 22 '17 at 8:00
3

The quick and dirty way that I do it in dev on a regular basis is to:

  1. Replace your reporting database with a new DB from the sitecore zip file /databases.
  2. Using robomongo, log into Mongo and delete your xDB databases. ([yoursite]_analytics, [yoursite]_tracking_contact, [yoursite]_tracking_live, [yoursite]_tracking_live).

When you visit the site for the first time, Sitecore will make new xDB databases in Mongo.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.