3

I am setting up commerce server site. But I can't access CSServices site. I followed all steps mentioned at commercesdn site:

  • Create a folder named C:\inetpub\CSServices\ In IIS, add a new website named CSServices, with the physical path pointing to the folder that you previously created.

  • Make sure this IIS site listens on port 1004, which will be used in a later stage. Create a new app pool "CSServices", and set its identity to .\CSFndRuntimeUser Depending on your IIS hostname binding, you may need to disable the loop back check. Please refer to http://support.microsoft.com/kb/896861 for more details.

I run commands to grant admin rights as well.

But can't access following url: http://localhost:1004/CFSolutionStorefrontSite_CatalogWebService/CatalogWebService

It is showing below error: HTTP Error 401.2 - Unauthorized You are not authorized to view this page due to invalid authentication headers.

3

You need to make sure:

1- the user CSFndRuntimeUser is an administrator

2- on the CSService on IIS you set Windows Authentication and Anonymous Authentication as enabled

2.1 - on the Catalog and Profile sites on IIS you set only Windows Authentication as enabled

| improve this answer | |
0
  • Set CSSServices authentication to Anonymous
  • Set CSSServices\CFSolutionStorefrontsite_CatalogWebService authentication to Anonymous
  • Set CSSServices\CFSolutionStorefrontsite_ProfilesWebService authentication to Anonymous
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.