4

I've got a few automated email campaigns in Sitecore 9.0 Update-2 that I created from existing pages. I've noticed that if I modify the content or presentation of those pages, the automated emails do not send the latest content; rather, they send an older version of the pages.

Publishing makes no difference--the only way I've been able to get the automated email campaigns to send the latest content is by restarting Sitecore. Is there a cache that I need to clear somewhere?

4

EXM Automated Messages keep a Message Cache that stores the contents of the file. If you are changing content of an Email Item and not seeing the content change when dispatching it is likely because you haven't Deactivated the email message.

This can happen if you directly edit an Email Message either by Unprotecting The Email Item, or directly editing a child item though the content editor.

To Fix or to Correctly Edit an Automated Message

  1. Go into EXM UI in Sitecore, click on Automated messages, and find the message you are desiring to edit.
  2. Click on the Delivery Tab
  3. Press the Deactivate button.
  4. Edit the message (if you have additional edits to make)
  5. On the Delivery Tab, press the Activate button.

This will reactivate the message and refresh the Message Cache.

Hope this helps!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.