2

I'm currently trying to install Sitecore 8.1 rev. 160519 using SIM Tool 1.4.0.92 rev 150618 and I'm getting this error message in the logs:

>    1 12:48:04,739 ERROR Service WAS was not found on computer '.'.
System.InvalidOperationException: Service WAS was not found on computer '.'. ---> System.ComponentModel.Win32Exception: The specified service does not exist as an installed service
   --- End of inner exception stack trace ---
   at System.ServiceProcess.ServiceController.GenerateNames()
   at System.ServiceProcess.ServiceController.get_ServiceName()
   at System.ServiceProcess.ServiceController.GenerateStatus()
   at System.ServiceProcess.ServiceController.get_Status()
   at Microsoft.Web.Administration.ServerManager.GetServiceStatus(String serviceName)
   at Microsoft.Web.Administration.ApplicationPool.get_State()
   at SIM.Adapters.WebServer.Website.get_ApplicationPoolState()
   at SIM.Tool.Base.InstanceHelperEx.EnsureAppPoolState(Instance instance, Window mainWindow)
   at SIM.Tool.Base.InstanceHelperEx.PreheatInstance(Instance instance, Window mainWindow, Boolean ignoreAdvancedSetting)
   at SIM.Tool.Base.AuthenticationHelper.LoginAsAdmin(Instance instance, Window owner, String pageUrl, String browser)
   at SIM.Tool.Windows.MainWindowComponents.LoginAdminButton.OnClick(Window mainWindow, Instance instance)
   at SIM.Tool.Windows.MainWindowHelper.c__DisplayClass2d.b__25(Object param0, RoutedEventArgs param1)

The other symptom is that IIS refuses to start my site.

This is occurring on a Windows Server 2012 R2 machine.

Has anyone encountered this message before?

5
  • Have you checked this one serverfault.com/questions/384237/… ?
    – Marek Musielak
    Oct 18, 2016 at 16:54
  • Have you tried run as administrator? And if you have .NET Framework 3.5 installed? Oct 18, 2016 at 16:57
  • @Marek is right; this question is asked and answered here: serverfault.com/questions/384237/…
    – Mark Cassidy
    Oct 18, 2016 at 17:17
  • @Marek you were right ^^ I was indeed missing Window Process Activation Service >> Process Model on my Windows 2012 machine. Thanks to you, I was able to solved my problem :D
    – Frederic
    Oct 18, 2016 at 18:04
  • @Frederic you're welcome. I converted my comment into an answer
    – Marek Musielak
    Oct 18, 2016 at 18:48

1 Answer 1

5

You're missing Windows Process Activation Service on your computer.

Check Control Panel > Programs > Programs and Features > Windows Process Activation Service.

More details here: https://serverfault.com/questions/384237/service-was-was-not-found-on-computer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.