0

I'm trying to install the Sitecore v9.3 with "Sitecore Install Assistance", however, I did get this error.

Note: The "Sitecore.IdentityServer 4.0.0 rev. 00257 (OnPrem)_identityserver.scwdp.zip" file does exist.

Log File:

Unable to parse [resolvepath(variable('IdentityServer_Package'))] - Exception calling "InvokeWithContext" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Cannot find path 'C:\Users\erjan\Desktop\Sitecore\Sitecore Installations\Sitecore 9.3\Graphical setup package for XP Single\pacakges\Sitecore 9.3.0 rev. 003498 (Setup XP0 Developer Workstation rev. 1.1.0-r105)\Sitecore.IdentityServer 4.0.0 rev. 00257 (OnPrem)_identityserver.scwdp.zip' because it does not exist."

SIA Error:

Sitecore Install Assistance - SC v9.3 installation error.

0

I did find a solution to this issue. It looks like a similar issue happened when Sitecore v9.3 is installed by using the "Sitecore Installation Framework" PowerShell scripts. Instead of updating "install.ps1" you have to update "setup.exe.config" file.

Solution:

  1. Open the file "setup.exe.config" file which is under the root folder of the installation package that you downloaded from Sitecore (Sitecore 9.3.0 rev. 003498 (Setup XP0 Developer Workstation rev. 1.1.0-r105))
  2. Search for value=".\Sitecore.IdentityServer * rev. * (OnPrem)_identityserver.scwdp.zip"
  3. Update the value with the actual file name like value=".\Sitecore.IdentityServer 4.0.0 rev. 00257 (OnPrem)_identityserver.scwdp.zip"

  4. Save an restart the installation process.

Note: If this does not work. Rename the "Sitecore.IdentityServer 4.0.0 rev. 00257 (OnPrem)_identityserver.scwdp.zip" for something simple like "IdentityServer.scwdp.zip" update the "setup.exe.config". Restart the installation process. This will work.

I have recorded a Sitecore Tutorial and explained how to install Sitecore v9.3 and in this video, I also explained how I solved this issue.

https://www.youtube.com/watch?v=pFyLQEkz3U8&t=4s

0

Faced the same issue.

It was because of my FULLPATH name length to 'Sitecore.IdentityServer 4.0.0 rev. 00257 (OnPrem)_identityserver.scwdp.zip' was more than Windows MAX_PATH limit (260 characters).

In your case full path name length is 266 characters:

enter image description here

Just solved by moving to installation files to 'D:/s93install'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.