3

Sitecore XP 9.2.0 installation fails with the error. enter image description here

Sitecore Install Assistant suggests checking the log. The log file contains the following entries:

                      ************************************
                           Sitecore Install Framework
                                 Version - 2.1.0
                      ************************************


WorkingDirectory       : C:\Users\XXX\Downloads\Sitecore\Sitecore 9.2.0 rev. 002893 (Setup XP0 Developer 
                         Workstation rev. r150)
WhatIf                 : False
Verbose                : SilentlyContinue
Configuration          : C:\Users\XXX\Downloads\Sitecore\Sitecore 9.2.0 rev. 002893 (Setup XP0 Developer 
                         Workstation rev. r150)\XP0-SingleDeveloper.json
Debug                  : SilentlyContinue
AutoRegisterExtensions : False
WarningAction          : Continue
ErrorAction            : Stop
InformationAction      : Continue





[------------------- GeneratePasswords : SetVariable -------------------------]

[ IdentityServerCertificates_CreatePaths : EnsurePath --------------------------]
[IdentityServerCertificates_CreatePaths]:[Create] C:\certificates

[ IdentityServerCertificates_Display... : WriteInformation --------------------]
Certificate Password: )QjbMu:>806^G#60XPmO

[ IdentityServerCertificates_CreateR... : NewRootCertificate ------------------]
Found multiple certificates, selecting certificate with longest expiry.
Exported certificate file C:\certificates\SitecoreRootCert.pfx

[ IdentityServerCertificates_CreateS... : NewSignedCertificate ----------------]
Found multiple certificates, selecting certificate with longest expiry.
Could not find Cert: sc-xp-920identityserver.dev.local in Cert:\LocalMachine\My
Exported certificate file C:\certificates\sc-xp-920identityserver.dev.local.pfx

[---------- IdentityServer_CreatePaths : EnsurePath --------------------------]
[IdentityServer_CreatePaths]:[Create] C:\inetpub\wwwroot\sc-xp-920identityserver.dev.local

[-------- IdentityServer_CreateAppPool : AppPool -----------------------------]
[IdentityServer_CreateAppPool]:[Create] sc-xp-920identityserver.dev.local
[IdentityServer_CreateAppPool]:[Setting] processModel.identityType => ApplicationPoolIdentity
[IdentityServer_CreateAppPool]:[Setting] managedRuntimeVersion => 
[IdentityServer_CreateAppPool]:[Setting] processModel.loadUserProfile => True
[IdentityServer_CreateAppPool]:[Setting] processModel.idleTimeoutAction => Suspend

[ IdentityServer_SetAppPoolCertStore... : FilePermissions ---------------------]
[IdentityServer_SetAppPoolCertStorePermissions]:[Allow] IIS AppPool\sc-xp-920identityserver.dev.local
[IdentityServer_SetAppPoolCertStorePermissions]:[Path] C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys\5bbbe01bf59748c5204d66d57ec057b5_bf574485-a3b5-4063-83ca-fcdd6c376d2b
[IdentityServer_SetAppPoolCertStorePermissions]:[Rights] Read
[IdentityServer_SetAppPoolCertStorePermissions]:[Inherit] None
[IdentityServer_SetAppPoolCertStorePermissions]:[Propagate] None

[-------- IdentityServer_CreateWebsite : Website -----------------------------]
[IdentityServer_CreateWebsite]:[Create] sc-xp-920identityserver.dev.local
[IdentityServer_CreateWebsite]:[Setting] applicationPool => sc-xp-920identityserver.dev.local
[IdentityServer_CreateWebsite]:[Setting] physicalPath => C:\inetpub\wwwroot\sc-xp-920identityserver.dev.local

[---------- IdentityServer_StopWebsite : ManageWebsite -----------------------]
[IdentityServer_StopWebsite]:[Stop] sc-xp-920identityserver.dev.local
The property 'Value' cannot be found on this object. Verify that the property exists.
[TIME] 00:00:08
The property 'Value' cannot be found on this object. Verify that the property exists.
  • seems it's crashing when stopping ID server? Did it actually create it? – josedbaez Aug 15 '19 at 13:37
  • 2
    First check if "sc-xp-920identityserver.dev.local" is setup as windows service and it is running. Then check if it is setup on the IIS and is running including AppPool. Also make sure that your IIS is running. – Ercan Polat Aug 15 '19 at 23:52
  • I had the same issue and solved it by starting the "Windows Process Activation Service" and the "World Wide Web Publishing Service" manually. – Sebastian Lay Oct 7 '19 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.