1

I am running Sitecore Helix.Example for Sitecore.JSS + .Net Core Rendering Host. In addition it is wrapped with SXA to be able to use all SXA advantages like multisite management and so on. In normal mode everything looks good. When I open site in a browser, it looks as expected:

enter image description here

But when I open the Home page in Experience editor, it looks a bit strange: all components from main placeholder is unknown but technically they are similar with header and footer whose are rendered fine in EE:

enter image description here

Does anybody have any idea where to look at?

2
  • Did you import your components (Hero Banner, Promo Container, ...) into Sitecore? Looks like Sitecore is not aware of them. Jul 28 at 7:35
  • Component are in Sitecore for sure :) The issue with EE only. Site itself is rendered fine. But basically I know what is the issue already. I will add answer soon. Jul 28 at 10:31
1

By default, JSS uses a jss Layout Service configuration. And when we just created a new Rendering Host from sitecore.aspnet.gettingstarted template, Rendering Host has LayoutServicePath setting which is pointing a Layout Service by the following path: /sitecore/api/layout/render/jss, where the last node in the path is jss configuration. So here everything works as expected.

But then I have installed SXA. And it has own Layout service configuration which is called sxa-jss. I assume we need that to be able to use Page and Partial Designs. So, when I was requesting the page from browser directly to the Rendering Host - it was using jss configuration and all was working fine. But when I tried to open page in Experience Editor - it was using sxa-jss configuration which is set in the site settings and returning me the Unknown component 'Component name here'. And when I changed the Rendering Host setting to use sxa-jss as well - I got the same result as in EE.

So, I found how to solve it. Basically, it appears when Rendering item has spaces in the name. Which seems SXA bug... I just have renamed all my rendering and it became working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.