0

I am installing Install Sitecore 9.1.0 using PowerShell script and getting the following error:

Unable to connect to target server. Please verify the connection information such as the server name, login credentials, and firewall rules for the target server.

enter image description here

Although I already verified SQL server credentials that didn't help.

6
  • Can you verify your SQL Server version? Aug 29, 2022 at 9:50
  • 1
    How have you verified the SQL connection? Is it possible malformed connection string? Have you confirmed correct port is open and it is correctly in conn string? Aug 29, 2022 at 10:29
  • I saw that in the compatibility table it's the same as required. Aug 29, 2022 at 10:36
  • you need to specify the SQL Server Name in the config. You can get it by logging into your SQL Server instance Aug 31, 2022 at 8:30
  • In your snapshot, it says that 'network path was not found'. That should be your starting point to fix it. I also think that SQL server may not have remote access enabled which can be done by running following query - EXEC sp_configure 'remote access', 0; GO RECONFIGURE; GO
    – Ghan
    Aug 31, 2022 at 8:58

1 Answer 1

0

The installation of Sitecore 9.1.0 requires Sitecore Installation Framework version 2.0.0. See this table for more info:

Sitecore Sitecore Installation Framework
9.0.x 1.2.1
9.1 2.0.0
9.1.1 2.1.0 or later
9.2.0 2.1.0 or later
9.3.0 2.2.0
10.0.0 2.3.0

It seems you're currently using version 2.3.0 based on the error message. So you should first install the correct version.

Install a specific version of SIF

Install-Module -Name SitecoreInstallFramework -RequiredVersion x.x.x

Use a particular version of SIF for installation - this is important when installing

Import-Module -Name SitecoreInstallFramework -Force -RequiredVersion x.x.x

This info is based on this blog: https://kezhan.info/2020/09/10/Sitecore-Installation-Framework-and-Sitecore-Versions-Compatibility-Table

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.