0

I am trying to setup Sitecore 10.3 with docker containers. While trying to run the .\up.ps1, I am facing below error with the certificate while building the containers:

enter image description here

enter image description here

Unable to load the service index for source https://sitecore.myget.org/F/sc-packages/api/v3/index.json.
An error occurred while sending the request.
The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.
The remote certificate is invalid according to the validation procedure.
The command 'powershell -Command $ErrorActionPreference = 'Stop'; $ProgressPreference = 'SilentlyContinue'; nuget restore -Verbosity quiet' returned a non-zero code: 1
ERROR: Service 'solution' failed to build : Build failed
C:\sitecore\jss\docker\jssdoc\up.ps1 : Container build failed, see errors above.
At line:1 char:1
+ .\up.ps1
+ ~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException
+ FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,up.ps1

I have verified and the pem files are getting created. I also set the environment variable as mentioned here: https://doc.sitecore.com/xp/en/developers/hd/210/sitecore-headless-development/walkthrough--configuring-sitecore-ca-certificates-for-node-js.html

enter image description here

2
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Richard Seal
    Jan 4, 2023 at 16:03
  • I had Zscaler acting as the MITM causing the certificate issue. I got it resolved by importing the certificate to the container. This helped: vincent-lui.medium.com/…
    – Anonymous
    Jan 19, 2023 at 9:21

1 Answer 1

0

Upload the valid certificates in traefik folder and change the path in certs_config.yaml file.

The path of certificates is shown below,

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.