4

Anyone got the same issue upon the provisioning of Sitecore Web Experience Manager (XM) using Azure PaaS offering.

I've just followed the steps provided in Azure with $50 remaining credits in my account, but while the 'deployment in progress...' suddenly it failed after 20-30 minutes.

enter image description here

  1. Create a new Resource Group name
  2. Configure the Sitecore Settings

    • Version: v.8.2 Update 4 or Update 5

    • Topology: Sitecore Web Experience Manager (XM)

    • Size: 1-3

    • Location: West Europe (Tried Southeast asia too)

    • Application Insights: West Europe

    • Credentials: *****

  3. Accept the License Agreement and hit OK.

Here's the error message:

enter image description here

Code:

{  
   "status":"Failed",
   "error":{  
      "code":"ResourceDeploymentFailure",
      "message":"The resource operation completed with terminal provisioning state 'Failed'.",
      "details":[  
         {  
            "code":"DeploymentFailed",
            "message":"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details.",
            "details":[  
               {  
                  "code":"BadRequest",
                  "message":"{\r\n \"code\": \"BadRequest\",\r\n \"message\": \"Bad Request\",\r\n \"innererror\": {\r\n \"diagnosticcontext\": \"f4007f36-398d-4f6f-a408-8eca6d373549\",\r\n \"time\": \"2017-10-24T03:58:53.3083676Z\"\r\n }\r\n}"
               }
            ]
         }
      ]
   }
}

Moreover, I've checked this article from MS on how to troubleshoot azure deployment issues, but it doesn't totally makes sense to me as it's just plain and simple 'follow-the-steps-in-azure' - https://docs.microsoft.com/en-us/azure/azure-resource-manager/resource-manager-common-deployment-errors

[Update-1] To add, the resources are visible and I can go to each details.

enter image description here

I can even hit the URL of the Sitecore CM and the page will load fine. However, I have noticed that upon page load it will display the azure page and not the sitecore default homepage, also the /sitecore/login is not accessible.

enter image description here

Note that I've done this few months back, but then when I tried now I received this error.

Any ideas?

  • I am trying to create a Sitecore Experience Cloud v9 using Microsoft Azure and I am getting this error message: "code": "BadRequest", "message": "Bad Request", "innererror"...: It doesn't say much about the problem. I have Visual Studio Enterprise – MPN subscription. I removed the limits and added a payment method. Is anything else that I can do to create it? – grilosape Dec 11 '17 at 23:17
2

I have heard from the sitecore support, and it is related to the following know issue related to Visual Studio limited subscription: https://kb.sitecore.net/articles/915122.

Thus, to resolve the issue, try to remove limits by settings a payment method in your subscription.

This query is already answered.

0

Azure doesn't make it super easy to see the issues, but there is usually a more detailed error along with the basic error you've provided which is what helped me determine the exact error. I do believe there is an issue with a change Azure made in regards to SQL Azure compatibility which is possibly related (it was impacting me w/ my deployments). See this kb article for details: https://kb.sitecore.net/articles/755670. The SC ARM templates out on the GitHub repo have been updated to account for this, so you could deploy using PowerShell w/ those templates to see if that works for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.