We’re rewarding the question askers & reputations are being recalculated! Read more.

Questions tagged [device-detection]

Device Detection is technology that identifies what type of devices are accessing an organization's website. All questions around this technology should use this tag.

Filter by
Sorted by
Tagged with
0
votes
1answer
25 views

ActiveProvider for Device Detection returning null

I am trying to detect device through code but it's not working. However, my device based personalization is working fine. I've enabled device detection in config file already. I can see files under /...
3
votes
2answers
103 views

How can I check for a Bot using the DeviceDetection api

I'm trying to figure out how the DeviceDetection api can be used to detect Bots visiting the website. Sitecore version: 9.0.2 When specific pages get visit, I want to log if it is a bot or not. var ...
0
votes
0answers
46 views

Device Detection Rules not triggering

I am using Sitecore 9.0.1 where I have created a new device (in the name of "AMP") item under layout/device in my content editor. I would be configuring Layouts/Renderings (AMP files) in my page ...
0
votes
0answers
25 views

Sitecore making adaptive design as mobile friendly

I have a scenario where i need to make my site mobile friendly compliance . When i tested this with URL https://search.google.com/test/mobile-friendly , it always go to desktop layout so reports as ...
3
votes
0answers
47 views

Is it possible to remove 51 degree reference from sitecore 9 installation

We are using sitecore 9.0.2 for one of the project. We do not need device detection in the application and hence device detection is set to false in the config Sitecore.CES.DeviceDetection.config. ...
4
votes
1answer
104 views

How to solve Device Detection 404 Not Found error in Sitecore 9.0.2?

I'm currently working on a Sitecore upgrade for my company but have found that the device detection is causing huge slow down. Disabling the device detection speeds things right along but while ...
3
votes
1answer
953 views

Device Detection Not Working on Vanilla Sitecore 9.0.1

I am trying to utilize the built-in Device Detection that is provided out-of-the-box with Sitecore 9.0.1. Reading all of the documentation on this, it appears that this is enabled automatically ...
5
votes
1answer
791 views

Enabling Sitecore Device Detection

When trying to run the following code on my local machine var _deviceCache = new DeviceDetectionCache(); var device = _deviceCache.GetDeviceInformation(Request.UserAgent) I am getting the following ...