2

I have deployed our Sitecore 9 application to an Azure Scaled PaaS XP environment.

i have used the marketplace and selected a 9.01 infrastructure.

Our automated deployment has succeeded and our code deployed to both the CM and CD instances. on the CM i can log into Sitecore, run unicorn and can preview the pages.

the problem is when i try and view the site from the root domain i get the error below...

The certificate was not found.

Stack Trace:

[InvalidOperationException: The certificate was not found.]
Sitecore.Xdb.Common.Web.CertificateWebRequestHandlerModifier.Process(HttpClientHandler handler) +276
Sitecore.Xdb.Common.Web.CommonWebApiClient1.CreateRequestHandler() +182 Sitecore.Xdb.Common.Web.CommonWebApiClient1.CreateClient() +56

the ARM templates from the marketplace have produced 3 instaced for xConnect, these are...

  1. xc-collect
  2. xc-refdata
  3. xc-search

we have a step on our GULP file that will deploy DLLs, XML and JSON to XConnect and i am yet to do this on our live environment but im convinced this error is not related.

any help is most appreciated.

JGilmartin

  • Have you checked the thumbprints in your ConnectionString? it should be the same with the connection string in CM/CD and the xc- sites? – Jovit Mayo Aug 29 '18 at 2:03
  • @JovitMayo - yes all the thumbprints are identical on all connection strings on all App Services. i have a ticket open with sitecore, ill post the solution once its resolved – JGilmartin Sep 4 '18 at 16:25
1

This Error occurred for 2 reasons...

1 ensure in your web config for the instance your working on (CM, CD) you have thr following attribute <add key="AllowInvalidClientCertificates" value="true"/>

2 in Azure make sure that in the App Settings you have for WEBSITE_LOAD_CERTIFICATES is set to a star -> *

once this is done, restart your app services and it will begin working

0

In your ARM template installation script, have you tried something as shown below. This worked for us without any issues.

$CertificateFile = "Path to your .p12 file"
$Parameters = @{
"authCertificateBlob" = [System.Convert]::ToBase64String([System.IO.File]::ReadAllBytes($CertificateFile))
}
Start-SitecoreAzureDeployment -Name $DeploymentId -location $Location -ArmTemplatePath $SCARMTemplate -ArmParametersPath $ParamFile -LicenseXmlPath $LicenseFile -SetKeyValue $Parameters
  • for this deployment rather than using ARM templates, Ive used the Azure Sitecore Marketplace Installation wizard for 9.01 – JGilmartin Aug 23 '18 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.