0

I am trying to Install Sitecore 10.1.1, while on first step, in prerequisite installation, I am getting below error:

"The term 'Get-PackageProvider' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again. The term 'Install-PackageProvider' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again. The term 'Install-Module' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again. The term 'Get-PSRepository' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again. The term 'Register-PSRepository' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again. The specified module 'SitecoreInstallFramework' with version '2.3.0' was not loaded because no valid module file was found in any module directory. "

can any one help ?

Regards, Sunil Rana

2
  • Do you have proxy set? Turn off proxy and try again Sep 11 '21 at 4:06
  • there is no proxy set. the issue looks mostly like version of Power shell mismatch. still investigating :-)
    – Sunil Rana
    Sep 12 '21 at 10:29
0

After trying to debug, I got it working. Ensure your PowerShell is having all the modules required to work.
in my case when I pasted the code "Get-Module -ListAvailable -Name PackageManagement

it only showed me C:\Program Files (x86)\WindowsPowerShell\Modules directory with 2 versions.

but when you are running the SIA exe, it will try to look for Powershell in C:\Users\<UserName>\Documents\WindowsPowerShell directory.

Solution:
All I did is copied the Configuration and Modules folder and pasted into this path.

I think we need to add the PowerShell path to Environment Variable Path. the only error you might get after that is version Upgradation. which can be easily achieved.

I hope this helps others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.