4

I changed content in one field in ContentEditor and then shifted to web database. Here I could see content change is not available which is fine because I haven't yet published but when I browsed the website that content change is being displayed.

How is it possible even I didn't publish that item. Is there any way to debug this behavior?

UPDATE 01/01/17

Following is multisite configuration at my laptop

Sitecore.config

<site name="SitecoreStaging" database="master" hostname="staging.sitecorewebsite.com" rootPath="/sitecore/content" startItem="/home" ...
<site name="SitecoreLive" database="web" hostname="www.sitecorewebsite.com" rootPath="/sitecore/content" startItem="/home" ...
<site name="website" database="web" rootPath="/sitecore/content" startItem="/home" ...

Binding

enter image description here

hosts entry

127.0.0.1 sitecorewebsite

127.0.0.1 www.sitecorewebsite.com

127.0.0.1 staging.sitecorewebsite.com

Now in this case If I browse all these mentioned URLs content only displayed from master DB even if for two website database attribute is set to "master" But If I remove other and keep only "sitecorewebsite" configuration then I can see web content i.e. not from master which is correct. Looks like I am missing something.

0

There are several reasons why this could happen. Since you do not see it in the web database, we can rule out auto-publish.

Check these just to make sure they are not the root cause

  1. You could be referencing the master database directly Sitecore.Data.Database master = Sitecore.Configuration.Factory.GetDatabase("master") Unlikely since you stated the item is not published.
  2. Sitecore could be in Live Mode There is an patch file included in App_Config/Include named LiveMode.config.example Make sure it is not enabled
  3. Make sure that the master database was selected and not the web database enter image description here

Multi-Site Configuration Edits

To properly configure multi-sites please on the SDN https://sdn.sitecore.net/Articles/Administration/Configuring%20Multiple%20Sites.aspx. You don't have access to the SDN. Also read John Wests blog https://community.sitecore.net/technical_blogs/b/sitecorejohn_blog/posts/sitecore-multisite-part-1-iis-challenges.

  • please see my updated post – Sukhjeevan Jan 2 '17 at 4:22
  • Look in App_Config/Include and make this LiveMode.config.example file is not enabled. in other words, it does not end with .config – C Sigmon Jan 2 '17 at 15:59
  • yeah it is LiveMode.config.example I mean not enabled – Sukhjeevan Jan 2 '17 at 21:09
  • What you have setup on your 1/1/17 update is for multi-tenant sites. I think what you may be trying to achieve is actually setup publishing targets. To check that, you should check your publishing targets though. You will find them under System/Publishing Targets – C Sigmon Jan 3 '17 at 1:52
  • No actually I'm trying to implement multi-site solution on single instance in sitecore and that's what I did on that update but even I specified database attribute different still getting content from master DB. Looks like there is something wrong I have done – Sukhjeevan Jan 3 '17 at 15:50
2

Your site might be running in live mode:

In Sitecore, you can run a website directly from the Master database – this is referred to as running in live mode. Running in live mode eliminates the need to publish content and is similar to viewing a website in the Preview client.

This would explain why you don't see the new value in the web database, but do see it when just browsing the site. Check the "database" setting of your site:

<site name="website" database="master" ... />

With a debugger your could also see what the context database is on your site.

More info in this question (with answers).

  • please see my updated post – Sukhjeevan Jan 2 '17 at 4:22
  • The issue the OP is having is not with Live Mode. – C Sigmon Jan 5 '17 at 3:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.