2

I can edit and view my custom SXA theme in the Experience editor with the Creative Exchange Live, but the theme doesn't appear on the website unless I publish the whole site.

I tried to publish the theme, the themes folder, the media library, but nothing work unless I publish the whole site and I would like to avoid this, since there could be a lot of content aka this could end taking a lot of time.

2

You need to publish the Site Theme through XA tab on the Experience Editor using Publish > Site Theme. See image below.

enter image description here

  • I tried it, but it doesn't update the theme unless I do a publish site :( – Simon Arnold Mar 21 '18 at 18:56
  • Are you getting any errors in the log? – Marco Mar 27 '18 at 20:26
2

Deploy if not Publishing

In order to evaluate the problem, You can go to the specific file in your theme and deploy it. This way, you will see that the file is published ( deploy is same as publish for theme files )

enter image description here

Theme Settings

Also make sure, you have set your desired theme in your Theme Settings. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.