3

I am running the XP1-SingleDevloper.ps1 and it is choking when trying to connect to the solr url. If I hit https://solr:8983/solr in a browser it comes up just fine. Thoughts on why it isn't able to connect?

[------------------------------ XConnectSolr_StartSolr : ManageService ---------------------------------------]
[XConnectSolr_StartSolr]:[Updating] Solr-7.6.0

Status   Name               DisplayName                           
------   ----               -----------                           
Running  solr-7.6.0         Solr-7.6.0                            



[------------------------ XConnectSolr_CreateCores [1] : ManageSolrCore --------------------------------------]
[XConnectSolr_CreateCores [1]]:[Requesting] https://solr:8983/solr
WARNING: [1/5] Request Failed: Unable to connect to the remote server
[XConnectSolr_CreateCores [1]]:[Requesting] https://solr:8983/solr
WARNING: [2/5] Request Failed: Unable to connect to the remote server
[XConnectSolr_CreateCores [1]]:[Requesting] https://solr:8983/solr
WARNING: [3/5] Request Failed: The request was aborted: Could not create SSL/TLS secure channel.
[XConnectSolr_CreateCores [1]]:[Requesting] https://solr:8983/solr
WARNING: [4/5] Request Failed: The request was aborted: Could not create SSL/TLS secure channel.
[XConnectSolr_CreateCores [1]]:[Requesting] https://solr:8983/solr
WARNING: [5/5] Request Failed: The request was aborted: Could not create SSL/TLS secure channel.
Install-SitecoreConfiguration : Could not complete request for https://solr:8983/solr - The request was 
aborted: Could not create SSL/TLS secure channel.
  • 2
    First thing is that is the wrong version of solr for 9.1. It needs 7.7.2. Also is that solr server on the same box or a remote box? Looks like a very issue with solr. Like the self signed cert is not in the trusted store. – Chris Auer Jan 26 '19 at 17:08
  • version 7.2.1 version worked, thanks Chris – Colema18 Jan 26 '19 at 20:54
  • I just noticed that I wrote to wrong version number. Nice catch. 7.2.1 is right. Glad to help. – Chris Auer Jan 27 '19 at 2:17
4

For anyone who comes in on this error message. Sitecore 9.1 requires SOLR version 7.2.1. Using another version will have adverse side effects.

Per https://kb.sitecore.net/articles/227897

  • 8.2 - 6.6.2
  • 9.0 - 6.6.2
  • 9.1 - 7.2.1
5

Apart from what Chris mentioned, the error is indicative of TLS version problem. So use this command in powershell before you run the SIF install script.

[Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12

You can find this above solution mentioned https://stackoverflow.com/questions/41618766/powershell-invoke-webrequest-fails-with-ssl-tls-secure-channel

1

This error came for me, even though I used Solr version 7.2.1 for installing Sitecore 9.1.1 instance.

The problem was that the Solr cores were already been created with the same sitecore instance name that I now tried to install. You can check this in the Solr Cores URL (Replace port number 8984 with your port number in this URL). For example, if there is a core already with the name sc911_master_index and when we attempt to install a new sitecore instance again with the instance name as sc911, then also you will get the same error as below:

Install-SitecoreConfiguration : could not complete request for https://solr:8984/solr

SOLUTION:

  1. Either change the sitecore instance name that you want to install
  2. Or, UNLOAD the solr cores (with that same instance name that you're now trying to install) from the Solr Cores URL . You can do this by clicking on each core and then clicking the Unload button.

In my case, I unloaded the cores and then tried to run the installation script again, now this error is resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.