I tried installing Sitecore 9.3 (simple developer machine setup) with the Sitecore Install Assistant. I checked SXA to be installed.

In the config file (setup.exe.config) all parameters were set correctly and I added one more to install in a physical folder of my choice:

<parameter name="SitePhysicalRoot" value=".....\wwwroot" />

This worked perfectly for Sitecore, but when SXA was installed I got an error:

Cannot validate argument on parameter 'RootDirectoryPath'. Path 'C:\inetpub\wwwroot.....' does not exist

So apparently the SXA installation is looking for the default path?

1 Answer 1


Apparently the SitePhysicalPath is transferred en used in all of Sitecore jsons, but not in the one from SXA.

Quick fix: open SXA-XP0.json and find the Site.PhysicalPath variable (line 69). Adjust it to the path you installed the site, something like:

"Site.PhysicalPath": "[joinpath(environment('SystemDrive'), '...', '...', 'wwwroot', parameter('SiteName'))]"

A more elegant solution would be to add a parameter and use that one. To get the required json you should check how it is done for IdentityServer (or xconnect or Sitecore):

  • Add the parameter in the sxa-XP0.json
  • Replace the variable in sxa-XP0.json with a check for the parameter (copy the code from identityserver.json)
  • Add the parameters in SXA-SingleDeveloper.json just as it was done in XP0.SingleDeveloper.json (you will have 2 - the actual parameter and a reference with SXA: prefix)
  • Add the parameter in setup.exe.config in the SXAXPSingle template section just as it was done in the XPSingle template

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.